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Preface 

Epi Info™ is a public domain suite of interoperable software tools designed for the 

global community of public health practitioners and researchers. Perform data 

analysis with epidemiologic statistics, maps, and graphs. Build data entry forms, 

construct a database, and customize statistics applications. Physicians, 

epidemiologists, and public health officials without a technical background can 

easily work with critical data using Epi Info™ tools. 

Use this guide alone or as a supplement to other Epi Info™ guides. On the next 

page, view the complete collection of helpful guides available for Epi Info™ tools. 

The diagram shows how this guide, highlighted with the bookmark icon  fits into 

the big picture of the Epi Info™ suite. Additional guides may offer prerequisite 

information for the tool you’re working with. For example, if you’re working with 

Epi Info™ Form Designer, you’ll find it helpful by referencing the Epi Info™ Guide 

to Check Code, Command Reference, and Functions and Operators. The image 

below highlights the Guide to Form Designer with the prerequisite documentation 

icon ( ). You may find helpful other optional guides that are highlighted by the 

optional documentation icon ( ). 

 

 



 

 

The image below shows the interrelationships among the guides in the series. This 

guide is Getting Started with Epi Info™ Guide to Form Designer.  
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OVERVIEW

 

In Epi Info™ 7, the Form Designer and Enter Data work together to design the 

data entry process and collect data. You can use Form Designer to design surveys, 

questionnaires, and forms. You can customize the data entry screen and configure 

the data entry process and configure multiple options. Form designer helps you 

customize forms with validated data from the Enter Data tool. 

Epi Info™ 7 collects data and organizes it by project. Projects can have multiple 

forms, with multiple pages. For each page, we’ve added data entry fields capable of 

collecting data.  

 

Project Organization 
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Choose fields on the page which correspond to your data format analysis method. 

Different fields range from labels, text, numeric, and date types. You can choose 

from advanced fields like drop-down lists, data grids, and command buttons. View a 

list of field types in Figure 2.21.  

Epi Info™ 7 normally uses the Microsoft Access database format and stores new 

project data in the MS Access data file using an MDB extension. If you use 

Microsoft SQL Server, Epi Info™ 7 can natively uses SQL Server for data storage. 

Epi Info™ 7 manages the database, including table creation, managing keys, and 

other storage details. Building and designing forms shapes your database, so you 

can think of Form Designer as a unique database design tool. 
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Navigate the Form Designer Workspace

Open Form Designer by clicking Create Forms from the Epi Info™ 7 menu.  

 

 

Create Forms Menu  

 

Sample date: E. Coli project 



Epi Info™ 7 User Guide – Form Designer 

5 

 

• Menu toolbar — provides an easy way to access projects and gives you tools 

to edit your forms, manage your projects, and customize your canvas. 

• Project Explorer — Allows you to add pages, fields, and templates to a 

form. Expand or collapse each category by clicking the + or – buttons next to 

the category name.  

• The Canvas — Design your forms on The Canvas. Use the Field 

Definition dialog box to design and edit your form. You can customize the 

workspace by selecting fonts, colors, and grid options.  

 

Open a Recent Project 

Epi Info™ 7 comes with sample projects, templates, and examples to use for helping 

to showcase its many features and functions. The Sample project is one that 

contains several forms already prepared with pre-collected data. Schools of public 

health use these sample projects for teaching Epi Info™ as a part of the science of 

epidemiology and statistics.   

Open a recent project from the Form Designer menu, select File > Recent 

Projects. 

You can see a list of recent projects. If you open Form Designer for the first time, 

the sample project displays in the list. Become familiar with Form Designer by 

trying the sample project.  
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Opening a Recent Project 
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After selecting the Sample project, Form Designer opens the first page of the first 

form, labeled ADD Full.  

 

 First Page of Project 
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Create a new blank project and form 

Every Epi Info™ 7 project contains two files: the database file and a PRJ file, 

(project file) located in the project folder. The project file holds information about 

the database location and format. It also shows connection information, such as 

usernames and passwords. If you use Microsoft Access for your database, your 

project has an MDB file (Access database file) inside the project form. You can save 

the Access database file to any location. Projects that use an SQL Server database 

will only have a PRJ file in the project folder. 

To create a new project with forms, follow these steps: 

1. From the Epi Info™ main menu, select Create Forms. The Form Designer 

window opens. 

2. Click the New Project button on the toolbar or select File > New Project. 

The New Project window opens. 
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New Project dialog box 

3. Enter a Project Name. Project names cannot contain spaces or non-

alphanumeric characters. Underscores are permitted. 

4. Set the project location by typing it into the Location field or clicking the 

browse button. The default location for projects is the \Epi Info 7\Projects 

folder. 

5. Name your folder. Try something like the project name.  

6. Select the database format from the Data Repository drop-down list. The 

default option is Microsoft Access 2000-2003. You can use MS SQL Server if 

available. 
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7. If you selected Microsoft SQL Server for the Data Repository, then click the 

browse button. Enter the connection information for your SQL Server 

database. Contact your SQL Server administrator for help filling out the 

required fields in the dialog box below. Click OK. 

 

 

SQL Server Database dialog box 

• To set a new form name, tab to or click inside the Form Name field.  

• Enter a Form Name and click OK. A new blank canvas displays with the 

new form name and page on the tab at the top left of the canvas. Follow 

these rules for selecting a name for your form: 

Use only letters, numbers, and underscores. 

• Do not start a form name with a number. 

• Do not use any spaces. Use underscores like this: Form_1. 
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Before You Begin

 

Decide on a Naming Convention for Field Names 

Before designing your form, it is helpful to have a standard way to name the data 

fields (a naming convention). While Epi Info™ auto-suggests a name based on 

thethe question or prompt, in many cases, these suggestions are too lengthy or 

cumbersome. Creating your own standard naming convention while you assign 

fields for your forms will simplify your analyses.  The following suggestions may 

help: 

• Keep field names short.   

• Capitalize words within field names to help improve readability.  

For example, PatientLastName is easier to read than patientlastname. 

• Use a prefix to keep related fields together in alphabetized lists.   

Customize the Form Designer 

One of the most helpful things you can do before developing your questionnaire or 

survey form is to decide on the layout and overall look of the form.   

Consider these aspects while thinking about your design. 

• What font do you want the questions and entry fields to have? Set the 

Default Prompt and Default Input Fonts. You can specify the fonts. Go to 

Format > Set Default Prompt Font and Set Default Input Font. 

• How much space between fields? Adjust the settings for the grid. The grid 

square size and other grid settings are in Format > Grid Settings. 
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• Do you need a printed copy? If so, what paper size? Try using a corresponding 

page size when designing the form. You specify the page size in Format > 

Page Setup. 

• Decide on a portrait or landscape page orientation. Determine this by the data 

entry device or platform. Designing forms for websites or mobile devices, use a 

smaller page size and proper page orientation. You can set the page orientation 

in Format > Page Setup. 

• Would you prefer the question or prompt to appear above the Input Field or 

to the left of the Input Field? You can set the question and prompt 

positioning in Format > Page Setup. Select Vertical or Horizontal. 

• What screen resolution will probably be used for data entry? If the screen 

resolution is less than your defaults, reduce your resolution while designing 

the form. This maintains consistency of your field layout as you see it in the 

Enter Data tool.   

You can change these format settings while designing your form, but considering 

these questions first will save you time and rework. 

Note: Set the character font to on while adding fields to your form using the 

Format menu. 
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Set a Default Prompt or Input Field Font 

 

Default Prompt Font 

1. Format > Set Default Prompt Font. Shows the font dialog box. 

2. Select a font, font style, and size. 

3. Click OK.  

Default Input Font 

1. Format > Set Default Input Font. 

2. Select a font, font style, and size. 

3. Click OK.  

Change Grid Settings 

Use the Format settings to customize the Form Designer canvas. From the 

Form Designer toolbar, select Format. The drop-down menu opens, allowing 

you to customize your canvas. Select Format > Grid Settings to open the grid 

settings dialog box.  
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Grid Settings 

• Check the Snap to grid box to force the form fields to snap to the grid 

nearest the field edge. 

• Check the Show Grid box to see the grid as the canvas background. 

• Use the up and down arrows in the Grid Square Size field to alter the 

width between grid lines. 

• Select the Snap prompt to grid or Snap entry field to grid check boxes 

depending on the snapping effect you want to use. 

• Click OK. The Form Designer page displays with new settings. 

Set the Page Size, Orientation, and Default Prompt Alignment 

You can set the Page Size, Orientation, and Default Prompt Alignment using the 

Page Setup dialog.   
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Page Setup 

1. On the Form Designer menu, select Format > Page Setup.   

2. Set the page size to be any of the pre-configured sizes listed in the Size drop-

down list or use a custom size and specify the pixel width and height. 
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Page Size Setup 

1. Set the preferred page orientation – Portrait or Landscape. 

• Portrait orientation is good when printing data entry forms and when  

data entry is done from printed forms that have a portrait orientation.   

Portrait orientation may also be preferred for form uploads to small 

mobile devices, such as smart phones or tablets. 

• Landscape orientation is better for publishing forms to a website, using 

an Internet browser on a laptop or desktop. 

2. Set the default alignment to be vertical so the field is below the prompt 

and left aligned. Use horizontal alignment when the field is to the right 

of the prompt on the same row.  
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Default Label-Field Alignment 

 

Insert a Background Image or Color 

1. From the Form Designer toolbar, select Format > Background. The 

background dialog box opens. 



Epi Info™ 7 User Guide – Form Designer 

18 

 

 

 Background Format 

1. Set a background image under the Background Image section of the dialog 

box, Click Choose Image. The Background Image box opens.  

2. Locate the image file. Click Open. The image you select displays in the 

Background Image dialog box. Image formats include bitmap (bmp), 

picture (ico), and JPEG (jpg).  

3. Use the Image Layout drop-down list to customize the image on the screen 

(None, Tile, Center, and Stretch). 

4. From the image and color section, use the option buttons to Apply to all 

pages or Apply to the current page only. 

5. Click OK. The image displays in the form. 
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You can remove an image by following the steps below. 

1. Select Clear Image from the Background Image box.  

2. To set a background color, click Change Color. The color dialog box 

opens.  

3. Select a Background Color from the palette or select Define Custom 

Colors to enter a more specific color request. 

4. Click OK. Your color previews in the background box.  

5. Choose either Apply to all pages or apply to current page from the 

image and color section,  

6. Click OK. The color displays in the form of a background. To remove the 

color, select Clear Color from the Background Color box.  

Create a New Project from a Project Template 

Another way to create a new project is to use a pre-defined project template. This 

option creates the project with all the forms, pages, fields, and Check Code that are 

specified in the project template. Try out the collection of Epi Info™ sample 

templates. Locate the templates in Project Explorer under Templates > Projects.   

To use an existing project template, follow the steps below: 

1. Select File > New Project from Template. The New Project from Template 

window opens. Chose an available project template.  

2. Select the project template.  

3. Confirm the name and location of the new project, and the data format as 

shown in the window and make required changes. 
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4. Click OK. Form Designer begins constructing forms and fields. After a few 

moments, the first page of the project opens in the canvas. 

 

Create a New Form in an Existing Project 

1. Select File > New Form or right click on the project folder in the Project 

Explorer and select Add Form. The form dialog box opens. 

2. Type a Form Name.  

3. Click OK. Your new form displays in the Project Explorer, and the first 

page is visible in the canvas area. 

Open an Existing Project 

There are two ways to open an existing project. If the project you want to open is 

one of the four most recent projects you’ve opened, select File > Recent Projects 

and select the project from the list. Otherwise, click the Open Project button from 

the toolbar or select File > Open Project.  This shows the Open dialog box.  

Follow these steps: 

1. Navigate to the location of your project file and select a PRI file (project 

file).  If you do not have a project file already, you can navigate to 

the Epi Info™ projects folder and select one of the sample projects.  

2. Click Open. The project displays on the canvas. 

Note: Epi Info™ will only display files in the Epi Info™ project file format (PRJ).  

Close Project 

1. Click the Close Project button from the toolbar or select File > Close 

Project. 
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2. The project closes. 

Note: Epi Info™ automatically saves all changes to the project. There is no save 

function in Form Designer. 

Add a Page 

The Add Page function will add a blank page at the end of the form. To add a page, 

right click on the form in the Project Explorer and select Add Page from the  

context menu or select Insert > Page > Add Page from the toolbar.  

 

 

 

 

 

Add a Page 

Enter a page name in the Set Page Name dialog box and click OK. The blank page 

displays on the canvas and in the Project Explorer at the end of the form. 
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Set Page Name 

Insert Page 

The Insert Page function adds a blank page immediately before the current page 

showing on the canvas. To insert a page, right click on the page in the Project 

Explorer and select Insert Page from the context menu or select Page > Insert 

Page from the toolbar. 

 

Insert Page 

The new page shows on the canvas and in the Project Explorer immediately 

before the current page. 

Name a Page 

1. Right click on a page in the Project Explorer. Select Rename Page from 

the context menu.  
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Rename Page 

2. The Page Name dialog box opens. Enter a name in the Page Name field. 

 

Set Page Name 

3. Click OK. The page name displays on the list of pages. 

4. Right click on the page you want to delete and select Delete Page or select 

Edit > Delete Page from the toolbar. 

 

Delete a Page 
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Note: If there is only one page in the form, then you cannot delete the only page. 

 

 Primary page no delete dialog box 

Otherwise, a dialog box opens, prompting you to confirm deletion. Click Yes. The 

page is deleted. 

 

 Delete confirmation box 

Undo / Redo 

Most actions performed on the canvas are recorded including moving fields, copying 

and pasting fields, and changing field alignment. You can undo all recorded actions.  

Click Undo from the toolbar or Ctrl + Z to undo the most recent action on the list. 

Form Designer begins recording actions when it starts. Therefore, you can undo all 

actions up to your first action after opening Form Designer. 
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Click Redo from the toolbar or Ctrl + Y to redo the most recent action. Therefore, 

you can click Redo repeatedly and reinstate actions retracted by Undo. You can 

keep clicking and retracting actions up to the first time Undo was clicked.  

Form Designer remembers actions it can Redo but only for actions you changed by 

clicking Undo. As soon as you make new changes to the canvas, Redo actions are 

lost.   

Check Code 

Epi Info™ allows survey creators to guide the data entry process, adding data 

validation, automatic skip patterns, and automatic calculations. Check Code allows 

greater control and enhancements. Try out more complex functions such as 

mathematical or logical operations, comparing field values with each other, 

displaying helpful dialogs or creating custom error messages. Click the Check 

Code button to open the Check Code Editor. For more information about the 

Check Code Editor, refer to the Check Code section of the user guide. 

Enter Data 

Use Enter Data tool to record data into the data entry forms in Epi Info™ 7. Click 

the Enter Data button to open the current form in Enter Data. Enter Data can 

open independent, stand-alone, or parent level forms. If the form is a child form 

related to another parent form, then you cannot open it by clicking the Enter Data 

button. You must open the top parent form first, and then use the Relate button for 

the parent form to access the child form. This matches the record hierarchy in 

related table relationships.  

If a form does not yet contain a data table, Epi Info™ will ask you to create a data 

table. For information regarding the Enter Data, refer to the Enter Data section 

of the User Guide. 
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Fields

 

A Field, also known as a data entry field or input field, is where answers to  

questions are entered. Not all Epi Info™ 7 field types  receive data though, such as 

Label Fields and Command Buttons.   

Fields usually contain a question or prompt or some text describing collection data. 

In Epi Info™ 7, different fields collect data. View a list of  fields in the Project 

Explorer under the Fields category. Also, you can view fields when you right click 

on the Canvas and select New Field. 

 

 New Field context menu 
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Field Attributes 

Fields have properties or attributes that help control how they receive data. Each 

field type has a set of field attributes. Some options are not shown or disabled 

(grayed out) depending on the selected field type.  

A required field attribute makes a field mandatory during data entry. If a page 

contains fields marked with the Required attribute, Enter Data will not allow 

navigation or saves for partially completed records. A value must be supplied in all 

required fields.   

Caution! The Required attribute can cause a pause if the required information is 

not available at the time of data entry. It is best to use this attribute 

sparingly to avoid this situation.   

Check Code can set or unset therequired status for fields. For more information on 

this feature, refer to the topics in the Check Code Command Reference on the SET-

REQUIRED and SET-NOT-REQUIRED commands. 

• Read Only – prevents data entry into the field. Form Designer uses this to 

hold calculated or pre-populated values. You cannot place the cursor in the 

field. Also, since the cursor cannot enter a field with this attribute, Check 

Code written for this field won’t run. The Read Only attribute is useful for 

calculated fields that will not be directly changed (i.e., age, epidemiological 

week). Read Only and the Required attributes are mutually exclusive and 

cannot be used in combination. 

• Retain Image Size – used only for image fields. This attribute maintains 

the size of the original image and does not alter the size to fit the form image 

box. 
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• Range – enables a valid range with lower and upper limit fields. Only 

Number and date field types can have range values. If a value is entered that 

is less than the lower limit or greater than the upper limit, you will get a 

warning message. Missing values are accepted for fields unless you check 

Required Attribute. 

• Repeat Last – causes the field to populate with the last value shown in the 

field.  This may speed up data entry for fields that have the same value as 

the last entered record.  For example, if you enter many records from a clinic, 

set the Clinic Name field with Repeat Last attribute so it will add the 

clinic name from the last record. 

• Pattern – the required format for a field response.  

 

Font dialog box 
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Field Type Required Read 

Only 

Retain 

Image 

Size 

Range Repeat 

Last 

Pattern Web 

Survey 

Compatible 

Companion 

for Mobile 

Compatible 

Label/Title       X X 

Text X X   X  X X 

Test 

(Uppercase) 

X X   X   X 

Multiline X X   X  X X 

Unique 

Identifier 

        

Number X X  X X X X X 

Phone 

Number 

X X   X X   

Date X X  X X  X X 

Time X X   X  X X 

Date-Time X X   X    

Checkbox  X   X  X X 

Yes-No X X   X  X X 

Option       X X 

Command 

Button 

       X 

Image   X     X 
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Field Type Required Read 

Only 

Retain 

Image 

Size 

Range Repeat 

Last 

Pattern Web 

Survey 

Compatible 

Companion 

for Mobile 

Compatible 

Mirror         

Grids         

Legal 

Values 

X X   X  X X 

Comment 

Legal 

X X   X  X X 

Codes X X   X    

Relate         

Group       X X 

 

Field Attributes 

Add a New Field 

Click and drag the type of field you want to add from the Project Explorer to the 

approximate location on the canvas.  

You can also right click on the canvas in the location you want to add a field and 

select the field type from the New Field context menu.  

A Field Definition dialog box displays. The contents of the Field Definition dialog 

depend on the type of field you want to add.   
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Label/Title 

The Label/Title field allows you to have a title on the form or to give instructions 

or other information. Since this field type does not allow any data entry, it does not 

have Check Code, and is not searchable. The following figure is an example of a 

Label/Title field in Enter Data (circled in blue) based on the FoodHistory form of 

the sample E.coli project. 

 

Label/Title Field 

To complete the Label/Title Field Definition dialog: 

1. Enter some text for the Question or Prompt. The text you enter in this field 

displays on the canvas.  

2. Click in the Field Name text box. Epi Info™ automatically suggests a field 

name based on the Question or Prompt. However, it is very important that field 

names be short, and intuitive. Use the field name for data validation in Check 

Code and while performing analyses. Field names cannot start with a number or 

contain any spaces or non-alphanumeric characters (except the underscore 

character).  

Note: It is best to simplify the field name currently. You cannot change 

field names after data collection starts. 

3. Click the Font button to adjust the Question or Prompt font settings. 

Configure Titles with larger font or bolder text. 
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Label/Title Field Definition dialog box 

4. Click OK. The Label/Title displays on the canvas. 

 

Text Field 

The Text field is one of the most generic and common data entry fields used to 

capture text type data—letters, numbers, and symbols. Text fields hold up to 255 

characters in a single line. You can restrict the number of characters entered by 

specifying a maximum field size. Use Text fields for short questions such as name, 

address, occupation. The following figure shows how Text fields appear in Enter 

Data (circled in blue) based on the FoodHistory form of the EColi project. 
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Text field 

To complete the Text Field Definition dialog box: 

1. Enter the Question. The text you enter in this field will display on the 

canvas and prompt users to enter a response.  

2. Click in the Field Name text box or press the tab key. Epi Info™ 

automatically suggests a field name based on the Question. However, it is 

very important that field names be short, and intuitive. Use a field name for 

data validation in Check Code and when performing your analyses. Field 

names cannot start with a number or contain any spaces or non-

alphanumeric characters (except the underscore character).  

Note: It is best to simplify the field name. Field names cannot be changed after data 

collection starts. 
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3. You can limit how many characters you can type into this field by specifying 

the maximum number of characters using a number (e.g., 10 for ten 

characters).  If the maximum number of the character box is left blank, text 

fields can accept up to 255 characters. 

Note: Entering a maximum number of characters is optional. 

 

Text Field Definition dialog box 

4. Click OK. The Text field displays on the canvas. 

 

Text Uppercase 

The Text Uppercase field helps standardize entered data. All letters typed in this 

field are set to ALL CAPS. This field draws emphasis to the collected information. 

The following figure provides an example of how a Text Uppercase field displays 

in Enter Data (circled in blue) based on the Surveillance form of the Sample project. 
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Text (Uppercase) field 

To complete the Text Uppercase Field Definition dialog box: 

1. Enter the Question or Prompt. Added text in this field shows on the canvas 

and prompts users to enter a response.  

2. Click in the Field Name text box or press the tab key. Epi Info™ suggests a 

field name based on the Question or Prompt. It’s important that field names 

be short, and intuitive. Check Code uses the field name for data validation 

when performing analyses. Field names cannot start with a number or 

contain any spaces or non-alphanumeric characters (except the underscore 

character).  

 

Note: It is best to simplify the field name. Field names cannot be 

changed after data collection starts. 

3. You can add typing limitations for the field value by specifying the maximum 

number of characters using a number (e.g., 10 for ten characters).  If you 

leave the Maximum number of characters box blank, text fields can 

accept up to 255 characters. 
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Text (Uppercase) Field Definition dialog box 

4. Click OK. The Text Uppercase field displays on the canvas. 

Multiline 

The Multiline field is like the Text field but allows for several lines of text. This 

field type allows you to enter a large amount of text based on the question or 

prompt. The benefit of using this type of field is that a Multiline field can hold up to 

1 gigabyte of data or approximately two million characters. However, you can’t 

specify the maximum number of characters for a Multiline field the way you can 

with a Text field. Also, some analyses are more difficult with Multiline data. For 

example, you can’t sort data based on values in a Multiline field, so if sorting is 

important for your work, it may be better to use another type of field.  Multiline 

fields are most useful when capturing lengthy narratives and wordy, free-form, and 

descriptive data. The following figure provides an example of how a Multiline field 

displays in the Comment field (circled in blue) based on the Surveillance form of 

the Sample project. 



Epi Info™ 7 User Guide – Form Designer 

37 

 

 

Multiline field 

To add a Multiline field: 

1. Open the Multiline Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on 

the Canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™  suggests a 

field name based on the Question or Prompt. It’s important that field names 

be short, and intuitive. Check Code uses the field name for data validation 

when performing analyses. Field names cannot start with a number or 

contain any spaces or non-alphanumeric characters (except the underscore 

character).  

 

Note: It is best to simplify the field name. Field names cannot be 

changed after data collection starts. 
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Multiline Field Definition dialog box 

4. Click OK. The Multiline field displays on the canvas. 

Number 

The Number field only accepts numeric values. You cannot enter letters and most 

symbols into this type of field, apart from the negative sign (-) and the decimal point 

(.) Number fields can have a valid upper and lower range. You can specify a pattern 

for numbers that require a specific number of decimals. For example, if your data 

requires two decimal places, your number field could have a pattern that looks like 

##.## (where # is any decimal), which would allow a number between -9.99 to 99.99.  

Note: The negative sign occupies a place in the number field.  

Therefore, entering the number -7 into a field with this pattern would appear as         

-7.00, whereas the number 5 would appear as 05.00. The leading zeros are not 

included in calculations, analyses, or output. The following figure provides a 

highlighted example of how a Number field displays in the CaseID box (Enter Data) 

based on the FoodHistory form in the EColi project. 
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Case ID Enter Data field 

To add a Number field: 

1. Open the Number Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field displays on the 

canvas and prompts the user for a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™ 

automatically suggests a field name based on the Question or Prompt. It is 

important that field names be short, and intuitive. Check Code uses the field 

name for data validation when performing analyses. Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters 

(except the underscore character).  

 

Note: It is best to simplify the field name. Do not change field names 

after data collection starts. 

4. You can choose pattern from the Pattern drop-down list (optional). You can 

also create a new number pattern. Type in your new pattern using the # 

symbol and the decimal point as needed. The default setting is None. 

5. To limit the range of responses, check the Range checkbox (optional). Type a 

lower and upper limit in the Lower and Upper fields. 
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Number Field Definition dialog box 

1. Click OK. The Number field displays on the canvas. 

Phone Number 

The Phone Number field is like a number field, but with a pre-defined list of 

common phone number patterns. As with the Number field, letters and most 

symbols are not allowed. This field type is not supported in Web Survey or the 

mobile application. The following figure provides a highlighted example of how a 

Phone Number field displays in the Phone fields (Enter Data) based on the Case 

Report form of the Lyme project. 

 

Phone Number field 
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To add a Phone Number field: 

1. Open the Phone Number Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field displays on the 

canvas and prompts the user to enter a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™ 

automatically suggests a field name based on the Question or Prompt. 

However, it is very important that field names be short and intuitive. Check 

Code uses the field name for data validation when performing analyses. Field 

names cannot start with a number or contain any spaces or non-

alphanumeric characters (except the underscore character).  

 

Note: It is best to simplify the field name. You cannot change field 

names after data collection starts. 

4. You can choose a pattern from the Pattern drop-down list. The default 

setting is None. 

 

Phone Number Field Definition dialog box 



Epi Info™ 7 User Guide – Form Designer 

42 

 

5. Click OK. The Phone Number field displays on the canvas. 

Date 

The Date field is used to enter a date. The date format for data entry is determined 

by the regional settings of your computer. You can change the date format on your 

compute, but you can’t change the date format within Epi Info™ 7. The following 

figure provides a highlighted example of how date fields appear in Date of Interview 

field (Enter Data) based on the FoodHistory form in the EColi project. 

 

Date of Interview field 

 

To add a Date field: 

1. Open the Date Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field will display on 

the canvas and prompt the user to enter a response.  
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3. Click in the Field Name text box or press the tab key. Epi Info™ suggests a 

field name based on the Question or Prompt. It’s important that field names 

be short, and intuitive. Check Code uses the field name for data validation 

when performing analyses. Field names cannot start with a number or 

contain any spaces or non-alphanumeric characters (except the underscore).  

 

Note: You can simplify the field name.  You can’t change field names 

after data collection starts. 

4. You can limit the range of responses by checking the Range checkbox 

(optional). Enter a lower and upper date range into the Lower and Upper 

fields or select a date using the date calendar by clicking on the calendar 

icon. 
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 Date Field dialog box 

1. Click OK. The Date field displays on the canvas. 

Time 

The Time field is used to collect time data in hours, minutes, seconds, and AM or 

PM. The time pattern for data entry is determined by the computer’s regional 

settings where the pattern can be changed. You cannot change the time pattern 

within Epi Info™ 7. 

To add a Time field: 

1. Open the Time Field Definition dialog box.  
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2. Enter the Question or Prompt. The text entered in this field will display on 

the canvas and prompt the user to enter a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™ 

automatically suggests a field name based on the Question or Prompt. 

However, it is very important that field names be short, and intuitive. Epi 

Info™ uses the field name for data validation in Check Code and when doing 

analyses. Field names cannot start with a number or contain any spaces or 

non-alphanumeric characters (except the underscore).  

 

Note: Simplify the field name currently. You can’t change the Field 

names after data collection starts. 

 

Time Field Definition dialog box 
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4. Click OK. The Time field displays on the canvas. 

Date-Time 

The Date–Time field is used to collect data representing the exact date and time of 

a given moment. It is like a date field combined with a time field. The Date–Time 

pattern for data entry is determined by the computer’s regional settings. You can 

change the format using your computer’s settings, but you can’t change the date-

time format in Epi Info™ 7. This field type is not supported with forms published to 

Web Survey or the mobile application. The following figure shows a highlighted 

example of how a Date-Time field displays in Time Supper and Date Onset fields 

(Enter Data) based on the Oswego form of the sample project. 

 

Date-Time field 

To add a Date-Time field: 

1. Open the Date-Time Field Definition dialog box.  

2. Enter the Question or Prompt. The text entered in this field displays on the 

canvas and prompts the user to enter a response.  
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3. Click in the Field Name text box or press the tab key. Epi Info™ suggests a 

field name based on the Question or Prompt. It’s important that field names 

be short, and intuitive. Check Code uses the field name for data validation 

when performing analyses. Field names cannot start with a number or 

contain any spaces or non-alphanumeric characters (except the underscore).  

 

Note:  You should simplify the field name.  You can’t change Field 

names after data collection starts. 

 

Date-Time Field Definition dialog box 

 

4. Click OK. The Date-Time field displays on the canvas. 
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Checkbox 

The Checkbox field allows you to collect data by checking or unchecking a box. You 

can use multiple checkboxes to enter multiple responses in a study (e.g., symptoms 

or foods eaten). Checkbox fields collect binary data such as 0 or 1, true or false, yes 

or no. Responses are stored in the database as a 1 or 0 where 1 equates to yes and 0 

equates to no. When writing Check Code, (+) and (–) point to yes and no, 

respectively. Unlike the Yes-No field type, Checkbox fields do not contain missing 

values, so by default, regard checkbox fields as No. This changes when the box is 

checked during data entry or when Check Code assigns them a Yes value. Checkbox 

fields can be assigned a yes or no value and can never be set as required fields. The 

following figure provides a highlighted example of how Checkbox fields appear in 

the Foods Eaten field (Enter Data) based on the FoodHistory form of the EColi 

project. 

 

Checkbox field 

To add a Checkbox field: 

1. Open the Checkbox Field Definition dialog box.  
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2. Enter the Question or Prompt. The text in this field displays on the canvas 

and prompts the user for a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™  suggests a 

field name based on the Question or Prompt. It’s important that field names 

be short, and intuitive. Check Code uses the field name for data validation 

when performing analyses. Field names cannot start with a number or 

contain any spaces or non-alphanumeric characters (except the underscore 

character).  

 

Note: It is best to simplify the field name. You cannot change Field 

names after data collection starts. 

 

Check Box Field Definition dialog box 

4. Click OK. The Checkbox field displays on the canvas. 
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Yes-No 

The Yes-No field displays as a drop-down list on the canvas. Collected field data is 

a 1 or 0 where 1 = Yes and 0 = No. When adding Check Code, use (+) and (–) to 

identify a response as yes or no.  The default value for this field is blank. Check 

Code identifies a missing value as a (.). The figure below provides a highlighted 

example of how a Yes-No field displays in the stool sample and isolated fields (Enter 

Data) based on the FoodHistory form of the EColi project. 

 

Yes-No field 

 

In Enter Data the values for fields, Yes-No display in a variety of ways. You can 

customize data for your own analytics, including language translation. Keep in 

mind that database values are always 1 or 0.   

 

Yes-No Data:   

Yes No Missing 

True False Unknown 

(+) (-) (.) 
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Yes-No Data:   

Yes No Missing 

<custom setting> <custom setting> <custom setting> 

 

To add a Yes-No field: 

1. Open the Yes-No Field Definition dialog box.  

2. Enter the Question or Prompt. The text in this field displays on the canvas 

and prompts users to enter a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™ 

automatically suggests a field name based on the Question or Prompt. 

However, it is very important that field names be short and intuitive. Check 

Code uses the field name for data validation when performing analyses. Field 

names cannot start with a number or contain any spaces or non-

alphanumeric characters (except the underscore character).  

 

Note: Simplify the field name. You can’t change Field names after 

data collection starts. 
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Yes-No Field Definition dialog box 

4. Click OK. The Yes-No field displays on the canvas. 

Option 

The Option field creates a group box containing radio buttons. The radio buttons 

work for one-answer fields. Choosing a radio button influences other available 

options in the field. Database values are in a zero-based array. The first option is 0, 

the second is 1, the third is 2, and so on. The image below shows an example of two 

option fields.  You may select only one option. The field name is HaveOrEatCake.  

Since the first option is selected, the field HaveOrEatCake has the value of zero 

(0). In the next example, the field name is TrafficLightColor.  Since the selected 

color is the third option, the value of TrafficLightColor is two (2). 
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Option Field 

To add an Option field: 

1. Open the Option Field Definition dialog box and enter the Question or 

Prompt. The text you enter in this field displays on the canvas and prompts 

the user for a response.  

2. Click in the Field Name text box or press the tab key. Epi Info™ suggests a 

field name based on the Question or Prompt. However, it is very important 

that field names be short, and intuitive. Check Code uses the Field name for 

data validation when conducting analyses. Field names cannot start with a 

number or contain any spaces or non-alphanumeric characters (except the 

underscore character).  

 

 Note: It’s best to simplify the field name. You cannot change field names 

after data collection starts. 

3. Choose how the options display in the Option field by selecting Vertical or 

Horizontal from List options. 
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4. Choose the Options location by selecting Left or Right in the Start listing 

options on the left or right field. 

5. Use the Attributes field by select Right or Left. You can determine how the 

radio buttons align with the option text. 

6. Select the Number of Choices in the Attributes field. You can have a 

maximum of 16 options. The number of selected options corresponds to the 

number of rows under Option Definition. 

7. Enter the option name in each row of the Option Definition section. Click 

OK. The Option field displays on the canvas. 

 

 

 

Option Field Definition dialog box 
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Command Button 

The Command Button creates a clickable button on your form. You can use the 

button to run a specific block of Check Code. Below are examples of how you can use 

a Command Button (and its Check Code): 

• Compare the field values and perform automatic calculations. 

• Navigate through different pages within a form 

• Go back to a parent form if using a child form 

• Capture longitude and latitude coordinates from an address field. 

• Link to a website 

• Scan a barcode (when using mobile application) 

• Run a pre-written program in Classic Analysis. 

• Open a saved canvas in the Visual Dashboard. 

• Start other programs outside of Epi Info™ 7, such as Microsoft Excel or 

Outlook. 

Web Survey doesn’t support the command button feature.  The following image 

provides an example of how a Command Button displays in Enter Data (circled in 

blue) based on the FoodHistory form found in the EColi project. 
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Command Button 

Add a Command Button field: 

1. Open the Command Button Field Definition dialog box.  

2. Enter the Question or Prompt. The text in the field displays on the canvas 

and prompts the user to enter a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™ 

automatically suggests a field name based on the Question or Prompt. 

However, it is very important that field names be short and intuitive. Check 

Code uses field names for data validation while performing analyses. Field 

names cannot start with a number or contain any spaces or non-

alphanumeric characters (except the underscore character).  

 

Note: Simplify the field name. You can’t change Field names after 

data collection starts. 
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Command Button dialog box 

4. Click OK. The Command Button field displays on the canvas. 

Image 

The Image field allows for adding images to records. Examples of stock images: a 

patient’s photo, an image of a wound, rash or insect bite, a bacteria culture dish, or 

a sample vial barcode. If your data collection device is a smart phone or tablet, you 

can use your onboard mobile camera to add your own images. 

You can browse your device for images by clicking in the image field. Any of these 

formats will work:  Portable Network Graphics (PNG), Graphics Interchange 

Format (GIF), Joint Photographic Expert Group (JPG or JPEG), and Windows 

Bitmap Format (BMP).  

Caution: Windows Bitmap will not work with Web Survey. 



Epi Info™ 7 User Guide – Form Designer 

58 

 

 

Image field 

 

To add an Image field: 

1. Open the Image Field Definition dialog box.  

2. Enter the Question or Prompt. The Field text displays on the canvas and 

prompts the user to enter a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™  

automatically suggests a field name based on the Question or Prompt. It’s 

important that field names be short and intuitive. Check Code uses field 

names for data validation while performing analyses. Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters 

(except the underscore character ).  

 

Note: It’s best to simplify the field name. You can’t change field names after 

data collection starts. 
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1. You can disable the autofit feature by checking the Retain Image Size 

checkbox. By default, Epi Info™ expands/contracts the image to fit in the size 

of the Image field.   

 

Image Field Definition box 

2. Click OK. The Image field displays on the canvas. 

Mirror 

The Mirror field displays data captured in one field of the survey and adds it to 

another field usually located on a different page. It does not store data like the 

Windows clipboard, it only reflects data captured in other fields. This is useful when 

the same information wants to be displayed on multiple pages in a form (i.e., 

Patient Name, CaseID). Check Code cannot run on this field, and Mirror fields are 

not searchable because it doesn’t allow any data entry or have its own column in the 

database. 

Mirror fields also have the following attributes: 

• Mirror fields are read only. 
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• When the source field receives data or when it’s assigned a value in Check 

Code, the value of the field reflects in the Mirror field. 

• You can copy and paste Mirror fields to subsequent pages while in Form 

Designer. Mirror fields are read-only. 

• You can’t mirror Command buttons. 

The following figure is an example showing a form with three fields mirrored from 

Page 1 to Page 2. The Mirror fields on Page 2 are circled in blue. 

  

Mirror fields reflecting data  
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To add a Mirror field: 

1. Open the Mirror Field Definition dialog box.  

2. Enter the Question or Prompt. The displayed text in this field shows on the 

canvas and prompts you for a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™  suggests a 

field name based on the Question or Prompt. It’s important that field names 

be short, and intuitive. Field names are useful for hiding or revealing mirror 

fields in Check Code. Field names can’t start with a number or contain any 

spaces or non-alphanumeric characters (except the underscore).  

Note: It is best to simplify the field name. You can’t change Field 

names after data collection starts. 

4. Click the Assigned Variable drop-down list in the Attributes Group to show 

a list of variables that can be mirrored. 

5. Select the variable to be mirrored. 

 

Mirror Field Definition dialog box 
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6. Click OK. The Mirror field displays on the canvas. 

Grid 

The Grid field allows users to enter data in a spreadsheet on the page. This allows 

for simple and effective data entry for multiple data points. When you create a Grid 

field, you specify each column for the grid, the type of data for the column, and its 

size and properties.   

 

Grid Field 

Before deciding to use a Grid field on your form, please note the following 

limitations with Grid fields: 

• Some Field types are not supported as grid columns. Supported Field 

types include Text, Number, Date, Time, Date-Time, Phone Number, 

Checkbox, Yes-No, Legal Value, and Comment Legal. 

• Grid fields do not support Check Code. Check Code features like 

automatic calculations, skip patterns, enabling/disabling of fields, or other 

data validations, are not available to Grid fields. 

• Within Grid columns you can’t change the tab order. Pressing the Tab key 

moves the cursor to the next field from left to right. Pressing the Enter 

key moves the cursor within the same column, but down to the next row. 
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• Grid fields are not supported on Web Survey or mobile application. 

• Data on a grid field is stored as a separate table in the database. The table 

name in the database corresponds to the name of the field on the form. 

Steps for adding a grid field: 

1. Open the Grids Field Definition dialog box.  

2. Enter the Question or Prompt. The text displays on the canvas and 

prompts you for a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™ suggests a 

field name based on the Question or Prompt. However, it is very important 

that field names be short, and intuitive. When conducting analyses, Check 

Code uses the field name for data validation. Field names cannot start with a 

number or contain any spaces or non-alphanumeric characters (except the 

underscore character).  

Note:  Simplify the field name. You can’t change Field names after 

data collection starts. 

 

Grids Field Definition dialog box 
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You can click the Add button only after setting the Grid field Question or Prompt 

and it’s Field Name. 

4. Click the Add button. 

 

Grid Columns 

1. Type the column heading into the Enter Column Name for Grid text box. 

This text displays as a column heading on the form. 

2. Press Tab or click in the Column Name text box. Epi Info™ suggests a 

column name based on the Enter Column name for Grid field, however, it’s 

important that column names be short, and intuitive. The column name 

cannot start with a number or contain any spaces or non-alphanumeric 

characters (except the underscore character). 
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Note: Simplify the column name currently. You can’t change column names after 

data collection starts. 

3. Select the Column size from the Size drop-down list. Column size 

determines the number of characters that can fit in the column. The Column 

size setting works for Text type columns. Select the column format from the 

Column Type drop-down list. 

 

Grid Column Types 

4. After selecting Legal Values or Comment Legal column type, click the 

browse button next to the Data Source field and complete the steps outlined 

in the Legal Values and Comment Legal field sections below. 

5. Click Save Column to add the column to the grid.  

6. Repeat steps 1-5 for all the columns you want. 

7. Click OK. The Grid field displays on the canvas. 
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Legal Values 

A Legal Values field creates a drop-down list of choices on the field. Listed 

responses are the only respondent choices available. The following figure provides a 

highlighted example of how Legal Value fields appear in the Age, Race and Sex 

fields (Enter Data).  

 

 

Legal Values field 

To add a field for Legal Values: 

1. Open the Legal Values Field Definition dialog box.  

2. Enter the Question or Prompt. Your text displays in this field and on the 

canvas. Form Designer prompts you for a response.  



Epi Info™ 7 User Guide – Form Designer 

67 

 

3. Click in the Field Name text box or press the tab key. Epi Info™ suggests a 

field name based on the Question or Prompt. The field names be short, and 

intuitive.  Check Code uses Field names for data validation during analyses.   

Field names cannot start with a number or contain any spaces or non-

alphanumeric characters (except the underscore).  

 

Note:  Simplify the Field name. You can’t change Field names after 

data collection starts. 

 

Legal Values Field Definition dialog box 

1. Browse options for the Data Source field by clicking the Ellipsis (…) button 

to the right of the Data Source text box. 

2. Click Create New and enter your answer.  



Epi Info™ 7 User Guide – Form Designer 

68 

 

 

Set Up Code / Legal Links 

1. Enter the first value (e.g., Years). Press Enter or Tab and advance to the 

next value. 

2. Enter additional values until all your choices are in the drop-down list. 

3. Selecting Do Not Sort prevents values from appearing in alphabetical order. 

Otherwise, values show in the same order as they were entered. Click OK. 

Create legal values from Existing tables. 

1. Click Create New from Existing.  

Note: Create New from Existing uses a copy of the selected table. Changes to the 

original table won’t affect the new table. 
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2. Click Use Existing (Alternative to Create New from existing). Use 

Existing establishes a connection between your selected table and a new 

table. New changes made to the original table modifies the new table. 

3. Select a table from the drop-down list. Click OK.  

4. Click OK from the Field Definition box. The new field displays as a drop-

down list of values. 

You can import data from outside sources like MS Excel, and CSV files. Link it to 

the Legal Value field on your form. For information regarding importing data from 

outside sources, refer to the Visual Dashboard section – How to import data from a 

data source to use in a field. 

Comment Legal 

Comment Legal fields, like Legal Values, create a drop-down list of choices on the 

field. They are a list of values with character(s) typed in front of the values using a 

hyphen. During data entry you can see the code, hyphen, and the value such as M-

Male. However, only the code value in front of the hyphen is stored in the table like 

M in M-Male. The following figure shows how Comment Legal fields show in the 

State, Ethnicity, Race and Sex fields (Enter Data).  In the figure below, the value of 

1 is stored in the database if the Sex selected for the record is Male, 2 if the 

Ethnicity selected is Not Hispanic/Latino, and 5 if the Race selected is White.   

 

Comment Legal field 
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To add a Comment Legal field: 

1. Open the Comment Legal Values Field Definition dialog box.  

2. Enter the Question or Prompt. The text you enter displays on the canvas 

and prompts you for a response.  

3. Click in the Field Name text box or press the tab key. Epi Info™  suggests a 

field name based on the Question or Prompt. It is important that field names 

be short, and intuitive. Check Code uses field names for data validation 

during analyses. Field names cannot start with a number or contain any 

spaces or non-alphanumeric code (except the underscore).  

 

Note:  We recommend that you simplify the field name.  You can’t 

change Field names after data collection starts. 

 

Comment Legal Field box 

4. Click the browse button to the right of the Data Source text box. 
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From the Comment Legal values Data Sources, follow these steps: 

1. Click Create New and enter choices for the question.  

 

Set Up Code / Legal Links 

2. Enter the first value using the form code-hyphen-description as in AL-

Alabama where AL is the code and Alabama is the description. Pressing 

Enter or Tab advances you to the next value. 

3. Enter additional values using the same code-hyphen-comment format. All 

your items are added to the drop-down list. 

4. Selecting Do Not Sort results in values appearing in the order they were 

entered, not alphabetically. Click OK.  
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5. Use existing tables to create Comment Legal fields. 

Create Comment Legal Fields from Existing Tables 

1. Click Create New from existing (uses a copy from a selected table). 

Remember that changes to the original table won’t affect the new table. 

2. Use Existing (establishes a connection between the field and the existing 

table). Any changes made to the original table reflect in all fields that use 

this table as the source.  

3. Select a table from the drop-down list. Click OK. 

4. From the Field Definition box, click OK. The new field displays in the form of 

a drop-down list of values. 

You can import data from outside sources like MS Excel, and CSV files. Link it 

to the Comment Legal Value field on your form. For information regarding 

importing data from outside sources, refer to the Visual Dashboard section – 

How to import data from a data source to use in a field. 

Codes 

Like the Legal Values field, the Codes field creates a drop-down list of choices. The 

responses in the drop-down are the only choices available to the respondent. 

However, the values for the drop-down you select influence other values. Like a 

domino effect, other fields populate with predetermined values. At least two fields 

must exist; one which holds the selection code, and another to receive the value of 

the code. The first field holds the selection code in a drop-down list while 

subsequent fields populate, based on the primary values in the code table. The 

Codes field creates accurate user data. View the figure below. The Codes field 

displays to the right of the Disease field highlighted in blue (Enter Data).  
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Codes field 

Create a New Code Table 

1. Open the Codes Field Definition dialog box.  

2. Enter the Question or Prompt. The text displays on the canvas and 

prompts the respondent for an answer.  

3. Click in the Field Name text box or press the tab key. Epi Info™  

automatically suggests a field name based on the Question or Prompt, 

however, it’s important that field names be short, and intuitive. Check Code 

uses field names for data validation during analyses. Field names cannot 

start with a number or contain any spaces or non-alphanumeric characters 

(except the underscore character ).  

 

Note:  We recommend you simplify the field name.  You can’t change 

Field names after data collection starts. 
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4. Click on the field(s) to be linked from the Select field(s) to be linked to 

section. To select multiple fields, hold down the CTRL key and click each 

field.  This means that the fields to be linked to will need to be created before 

the Codes field. 

5. Click on the Data Source browse button. 

 

Disease Code field 

1. Click Create New. A spreadsheet opens for you to enter the values for 

the Codes fields and Linked fields.  
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New Code fields 

 

New Link fields 

2. The left-most column displays the selection field(s) in the Fields Definition 

dialog box. The column on the right shows the codes for each selection 

field. 

3. Enter the codes for each field.  
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4. Select the Tab key to move to the next field, or to the next row if you are 

at the end of a row. Click OK to accept the codes for each field. 

 

Selected Codes  

 

Use existing tables to create code tables. 

• Click Create New from Existing copies the selected table, but changes to 

the original table won’t be added.  

• Use Existing establishes a connection between the selected table and the 

new table. Changes made to the original table will modify the new table. 

Follow these steps: 

1. Select a table from the drop-down list, and then click OK.  

2. Click OK to close the Field Definition dialog box and place the fields 

in the form.  
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3. Test the code table by opening Enter Data and verify that both fields 

populate based on selections in the drop-down list. 

You can import data from outside sources like MS Excel, and CSV files. 

Link it to the Legal Value field on your form. For information regarding 

importing data from outside sources, refer to the Visual Dashboard section 

– How to import data from a data source to use in a field. 

 

Create Cascading Drop-Down Fields 

Cascading Drop-Down fields are multiple fields such as Code, Legal Value, or 

Comment Legal fields linked together. Each field filters the fields that come after it. 

Subsequent fields filter from earlier field selections. In the figure below, the drop-

down field for State filters the drop-down field for County. The county field only 

shows those counties in the State. When you select county, the drop-down field for 

hospital shows only regional county hospitals. 

For cascading drop-down fields, create a table complete with all the linked values 

you want to import into Epi Info™ 7. View the Excel spreadsheet shown below, 

named codeHospital. This is an example of a completed table with linked values. 

You must have a prefix code when importing this table into your Epi Info™ 7 

project. Here, it is codeHospital. 
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Completed table with links 

You can import data from outside sources like MS Excel, and CSV files. Link it to 

the Codes field on your form. For information regarding importing data from 

outside sources, refer to the Visual Dashboard section – How to import data from a 

data source to use in a field. 

Add cascading drop-down fields by following these steps: 

1. Add the first Codes field to the page but wait to link this field to other fields. 

You will do this a later step. In this example, we named the field 

StateName.  
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Adding Codes to cascading drop-down fields 

2. Add another Codes field to the page. Again, don’t link the field to other fields 

yet. In this example, we’ll name the second field County. Repeat this step for 

all but the last field in the sequence. In this example, we have only three 

fields to link, so the next field will be our last. 

3. Add the last field in our sequence. The last field should be a type other than 

a Codes field, such as Legal Value or Comment Legal. Since we won’t link 

other fields to this last field, avoid using the Codes fields. In our example, we 

have two Codes fields named StateName and County, and one Legal Value 

field named Hospital. 
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Adding Legal Values to cascading drop-down fields 

4. If using a Legal Value or Comment Legal field for the last field, click the 

browse button to the right of Data Source, which opens the Set-Up Code / 

Legal Links dialog. 

5. Click Use Existing, which opens the Open Form–Select a Table dialog 

box.  

6. Select the imported code table and click OK. In this example, we selected the 

codeHospital table. 
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Open Form Dialog Box 

1. Click OK. The Select a field dialog box opens showing the columns in the 

codeHospital table are linkable. 

 

Select a Field dialog box 
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2. Select the correct field. Because we are linking the Hospital field, we 

selected Hospital in this example.  

3. Click OK on the Select a Field dialog. The Set Up Code / Legal Links 

data source table shows the values from the Hospital column in the table. 

 

Data Source shows values for Hospital 

4. Click OK on the Set Up Code / Legal Links dialog box. 

5. Click OK on the field definition dialog.   

The next steps are for linking the fields with remaining Codes 

fields. 

1. Open the properties for the first Codes field by right-clicking the field and 

selecting Properties. Our first field was StateName and we want to link 

this field to the County field. Selecting StateName displays only counties 

in the State. 
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2. Select the field you want to filter. Select the County field since we want to 

filter Counties within a State. Click the Browse button to the right of Data 

Source. The Codes dialog opens.  

3. Click Use Existing which opens the Select a Table dialog box. 

4. Select the same code table for linking the last field. In our example, choose 

codeHospital.  

5. Click Link which opens the Match Fields dialog box. Here, we match our 

fields in cascading sequence to columns in the code table. 

6. Select the column you want to link to the first Codes field. Since our first 

field is StateName, lets select the column from our imported table named 

State. 

7. In the Link Associated Fields group, select the Form Field you want to 

link. For our example, we want County to be linked to State, so we selected 

County. 

 

In this section, we’ll work with Form Fields and Table Fields. 

1. In the Table Fields drop-down menu, select the corresponding column in 

the code table. 

2. Click Link. The linked field County displays in the Linked Fields box. 
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Match Fields Dialog Box 

3.  Click OK to close the Match Fields dialog. 

4. Repeat the steps 12 through 21 for each remaining Codes field in the 

cascading sequence. You can specify the next field in the cascading 

sequence and link it to the corresponding field in the code table. In our 

example, County is the only link remaining in the Code field. We’ll link 

this field to Hospital.  

 

Linked Fields 
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This completes the process of creating a series of cascading drop-down fields. Open 

the form in Enter Data. The first field will sequentially filter the values down to the 

next field. In our example, when selecting Florida for the State Name results in a 

list for only Florida Counties. 

 

State Name field filters values  

The StateName Codes field filters the County codes field. They are linked and 

display Florida counties like Alachua, Baker, Escambia, and Miami-Dade. They are 

the only Counties on the same row as Florida in the codeHospital table.   

 

The codeHospital table  

Likewise, when you select the county Alachua, only the values Alchua-Hosp1 and 

Alchua-Hosp2 display in the Hospital legal values field. 
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Relate 

A Relate field is used to establish a one-to-one or one-to-many relationship between 

parent form records and child form records.  For example, a survey may have a form 

devoted to general patient information.  This form may be related to another form to 

record the many hospital visits that each patient may have.  Related forms are 

linked automatically by unique keys generated by Epi Info™ 7.  In Enter Data, click 

the Relate Form button. The Relate Form button opens the first page of a related 

form. Using Check Code, you can make the Relate button conditionally accessible 

if you wanted to show a specific form for a particular disease. The following example 

shows how a Relate field displays on a form under Disease Specific Info as 

captured on the Surveillance form of the Sample project. 

 

Relate field 

To add a Relate field: 

1. Open the Relate Field Definition dialog box.  

2. Enter the Question or Prompt. The text you enter displays on the canvas and 

prompts the user to enter a response.  
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3. Click in the Field Name text box or press the tab key.  Epi Info™   suggests 

a field name based on the Question or Prompt. It’s important that field 

names be short, and intuitive.  Check code uses the field for data validation 

when doing analyses.   Field names cannot start with a number or contain 

any spaces or non-alphanumeric characters (except the underscore 

character). For Relate fields, it is recommended to match the field name to 

the name of the related form. 

 

Note:  You should simplify the field name. Field names cannot be 

changed after data collection starts. 

 

Relate Form Button dialog box 
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4. Select Create new form from the Relate Form drop-down list. Create a new 

form or select an existing form.  

• The dialog box will show the Accessible always button selected. This 

option cannot be modified. The Accessible only when the following 

conditions are true selector is not available in this version of Epi Info™ 

7. 

• Accessible always creates an always active Relate button in the form 

during data entry.  

• Accessible only when following conditions are true selector will be 

available in a future Epi Info™ release. However, you can create a 

conditional statement using Check Code see Epi Info™ 7 – Check Code. 

You can use Check Code to associate with the button and create a 

condition statement.  

5. Select Return to the parent form after one record has been entered. If 

you desire multiple entries, then leave this option unselected. This allows 

only one entry in the related form for each record in the parent form. In 

Enter Data, after saving a record in the related form, you’ll go back to the 

parent form.  

6. Click OK. The Relate Form button displays on the canvas. 

Group 

A Group field organizes multiple fields on a page for visual and practical purposes. 

Visually, a group field helps tie similar fields together into a common category. 

Group fields also provide organization and structure to a form. Add background 

color to a group to enhance its appearance. You can nest groups and arrange them, 

so specific fields overlap for Venn style diagramming on your form. 
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Nested Venn-style Group fields 

Group fields also have several practical purposes. In Classic Analysis and Visual 

Dashboard, you can run statistics on individual fields. If your fields belong within a 

group, then you can run some statistics on all fields within a Group field. 

Similarly, run several Check Code commands on all fields within a group by using 

just the group name. This makes commands such as Enable, Disable, Clear, 

Highlight, Set-Required, Set-Not-Required, among others, much easier. 
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Fields contained within the Group box are automatically members of the Group 

field. To remove a field from a group, simply drag the field outside of the group box 

boundary. Likewise, dragging the group box moves all fields within the group. Any 

fields within the boundaries of the group box are automatically members of the 

group field for analyses and Check Code execution. 

The following example shows how group fields (highlighted in blue) appear in Enter 

Data. 

 

Group field 
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Follow these steps to create a Group field. 

1. Click and drag a rectangle around the fields you want to group. 

2. Each field in the selection is highlighted with a rectangle. 

3. From the Form Designer toolbar, select Insert > Group or right click on a 

blank part of the canvas and select New Group Field from the context 

menu. The Group Properties dialog box displays. 

 

Group Field Properties 

• Enter the Question or Prompt. The text you enter in this field shows on the 

canvas and prompts the user to enter a response.  

• Click in the Field Name text box or press the tab key. Epi Info™  

automatically suggests a field name based on the question or prompt, 

however, it is very important that field names be short, intuitive, and usable. 

You can use the field name for data validation in Check Code and when doing 

analyses. Field names cannot start with a number or contain any spaces or 

non-alphanumeric characters (except the underscore character).  
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Note: It is best to simplify the field name. You can’t change the field 

names after data collection starts. 

Click OK to create the group. The fields appear in the group box. 

• Move the group by clicking and holding the group name with the mouse. 

• Resize the group box by moving the cursor over the group and adjust the 

box dimensions by clicking and dragging the corner of the box to the 

desired dimensions. If the new size includes additional fields, they become 

members of the group. 

• Fields and group fields sort the same way as on the Form Designer 

canvas. Click on the field and drag the field to the desired location. 

 

Edit an Existing Field 

Right click on the field and select Properties from the context menu, displaying 

the Field Definition dialog box. Make your changes and click OK.   

Edit a Field Name 

Field Names are critically important to Epi Info™ 7 projects because they are the 

basis for everything from database management to data validation, and analysis. 

Because field names are such an integral part of Epi Info™ 7 projects, you cannot 

change them after you create the data table. 
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Establish a concise and usable naming convention for your field names when 

starting a data entry form. Although Epi Info™ suggests a field name based on the 

Question or Prompt, it does so by concatenating the first several words together, 

stripping spaces and invalid symbols.  It’s convenient when the question is only a 

few short words. If your Question or Prompt frequently begins with “Please enter 

the” or “What is the,” suggested field names will display the same way. This creates 

a challenging and tedious experience. Searching for specific fields when writing 

Check Code, using Analysis Gadgets or Visual Dashboard becomes problematic. 

For these reasons, is very important that field names be short, and intuitive. Field 

names cannot start with a number or contain any spaces or non-alphanumeric 

characters (except the underscore character).  

 

When testing a form in Enter Data, a data table is initially created.  The field name 

cannot be changed after the data table is created.  If the data table has no data or 

only expendable test data, you can delete the data table so you can change the field 

name.  Refer to the topic Delete an Existing Data Table Without Deleting the 

Form for more information. 

Invalid Field Names 

Since field names cannot start with a number, if your question or prompt begins 

with a number, the pre-populated field name will begin with a leading letter N 

before the number.   

Field names cannot have spaces or non-alphanumeric characters other than the 

underscore.   

You can search fields by name in the database. Choose a unique name that doesn’t 

already exist in another field or form.   
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Finally, Epi Info™ needs to reserve some words for internal use to avoid conflicts 

related to database interaction.  For a complete list of reserved words, please see 

Appendix A: Reserved Words. 

If Epi Info™ flags your field name as invalid, it will appear in red font and the OK 

button won’t work.  To avoid this, change the field name slightly, perhaps add a 

suffix or prefix and make an acceptable variation of the name. Then click OK. 

Delete a Field 

1. Right click on the field, opening the context menu. 

2. Click Delete. 

Warning! The field any data are deleted from the form and database. Deletions 

occur immediately. No delete confirmation message displays before the field and its 

data are deleted. You can use undelete to recover the field, but once deleted, your 

data is unrecoverable. 

Copy, Cut, and Paste Fields 

1. Click and drag a rectangle around the fields you want to copy or cut.  

2. From the Form Designer toolbar, select Edit > Copy or Cut from the drop-

down list. 

3. Click in the new section of the form or select a new page in the project. 
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4. Select Edit > Paste. The copied fields appear in the form.  

When pasting fields, Epi Info™ suggests a field name based on the name in 

the original field.  To ensure the field name is unique, Epi Info™  adds a 

number. For example, if the copied field name is Age, then the pasted field is 

automatically named Age1.  Copying and pasting this field again results in a 

third field named Age11.  So, you can avoid errors while conducting analyses 

and when using in Check Code, you can change the field name.  Follow these 

steps: 

For each cut and paste Field, do the following: 

1. Right-click the new Field question or prompt and select Properties from 

the context menu. 

2. Click the text in the Field Name. You can now change the field name. Use 

clear, unique, and intuitive wordage.   

3. Field names cannot start with a number or contain any spaces or non-

alphanumeric characters (except the underscore character).  

Note: You can’t change field names after starting data collection, or with an 

existing data table.  

Note: You can also right-click on the field and use the context menu to copy or cut 

the field. Also, you can right-click the canvas and use the context menu to cut 

and paste a Fields. 

Align Fields 

There are several ways to align fields in Form Designer. Aligning fields with 

consistent formatting makes Forms look professional. Start aligning Fields by 

selecting the ones you want, and continue with the following steps: 
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1. Click and drag a rectangle around the Fields so you can align them. 

• To align the Fields vertically, select Format > Alignment > As Stack. 

• To align the Fields horizontally, select Format > Alignment > As 

Table. 

• For more options, right-click on the canvas to display all alignment 

configurations. Use Ctrl + (any whole number) to create additional 

alignment formats (e.g., Ctrl + 7 for seven columns). 

 

Field Alignment Options 

2. Choose additional options alignment options: 

• Align Selection in Column (s)—vertically aligns all fields with the 

correct number of columns (like Format > Alignment > As Stack). 

• Align Selection on Row—aligns all fields horizontally (like Format > 

Alignment > As Table). 

Set Field Size 

You can choose several field sizing options in Form Designer. Making field sizes 

consistent will allow you to make the look of your Forms more professional. 

Standardizing the Field size by selecting the them. Follow the steps below: 

1. Click and drag a rectangle around the Fields you want to re-size. 
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2. Right-click on the canvas to display all sizing configurations. 

 

Adjust Field Size 

3. Choose an option below: 

• Make Same Width (Use Maximum) — Adjusts selected fields’ width to 

match the widest field of the selection 

• Make Same Width (Use Minimum) — Adjusts selected fields’ width to 

match the narrowest field of the selection 

• Make Same Height (Use Maximum) — Adjusts selected fields’ height 

to match the tallest field of the selection 

• Make Same Height (Use Minimum) — Adjusts selected fields’ height to 

match the shortest field of the selection 

o Make Same Size (Use Maximum) — Adjusts selected fields’ height and 

width to match the largest field of the selection 

o Make Same Size (Use Minimum) — Adjusts selected fields’ height and 

width to match the smallest field of the selection 

Manually Set Field Size 

1. Hover your mouse over the Field to see the Field frame and sizing handles. 
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2. Hover the mouse over one of the sizing handles to see the mouse change to 

an arrow cursor. 

3. Click and drag a sizing handle to stretch the Field to the needed size. 

 

Manually Adjust Field Size 

Manually Set Field Position 

In certain cases, you’ll need to adjust the Field reposition it. In Epi Info™, the Field 

and prompt can move together or separately. This is especially helpful if using a 

right-to-left language where the question or prompt should be to the right of the 

entry field.   
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Manually Adjust Field Position 

The following example is based on a form containing a Label/Title field and a text 

field. 

 

Prompt and Entry Field Selection 

1. Click and drag the Field prompt to move a Field and question together, 

2. Click and drag the entry field, not the prompt, and you can move the Field 

and prompt separately as shown below. 
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Select Entry Field 

1. Release the Entry Field at the position you prefer. 

 

Adjust Entry Field Location 

 

Default Prompt Alignment 
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1. Right-click on the Field or prompt and select Default Prompt Align to 

restore the original field and prompt alignment to the default configuration,  

2. Select Format > Page Setup from the Form Designer menu bar. You can set 

the default alignment to vertical so the Field is below the prompt and aligned 

to the left, or horizontal where the field is to the right of the prompt. 

 

Default Label-Field Alignment 
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Tab Order 

 

In the Enter Data module, during data entry, pressing the Tab or Enter key will 

move the cursor to the next field.  Tab Order is the order or sequence that the 

cursor moves from field to field. The order that you’ve add fields to the form 

determines the initial tab order.  In many cases, as fields are moved around the 

page, added from a template, or pasted from somewhere else, the tab sequence may 

become disorganized.  Also, you may prefer the tab order to move in a custom way, 

such as down a column of questions, or maybe from right to left across the page. 

The proper tab order will make entering data more user friendly and efficient. 

Additionally, tab order determines how Fields display on a mobile device.  

Show the tab order by right-clicking on the canvas and select Tabs > Show Tab 

Order.  You can find the tab order for each field in a rectangle near the entry field. 

Red rectangles indicate the field is read only or the cursor cannot rest in that field, 

such as Label/Title fields. You cannot rest the cursor in group fields. A tab number 

is reserved for the group field, even though the tab order number for a group box is 

not shown.  

 

Show Tab Order 
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Start New Tab Order 

Right-click the canvas and select Tabs > Start New Tab Order from the context 

menu. Selecting this function will automatically set the tab order according field 

position from left to right, then top to bottom. 

Customize the Tab Order 

You can customize the tab order for your questionnaire requirements. This process 

begins by showing the tab order on the canvas. The example below demonstrates 

how to adjust the tab order in the food history form of the E.coli project, found in the 

projects folder.  

• Right-click the Canvas and select Tabs > Show Tab Order from the 

context menu to show the current order of field entry. 

 

Show Tab Order 

In the example shown in the figure above, the cursor moves in numbered sequence 

from left to right, row by row. 
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Suppose you wanted to have the order run down the first column, from Fresh 

celery to Bean sprouts, then over to the Grapes in the second column to Butter, 

and then over to Blueberries in the third column. There are a couple of methods to 

do this.  

Customize Tab Order using the mouse. 

1. Hover your mouse pointer over the field with the tab order showing what 

item you want as the first field in the sequence. In this example, we want to 

start the sequence with Fresh celery at tab order 3. A pop-up window 

displays showing the options available to reset the tab order. 

 

Tab Order Prompt 

 

2. Click on the tab order black box number to set the index. In this example, 

we click the number 3, to set the index at 3. 

3. Click on the tab order black box number for the next field you want to 

follow the index field. In our example, the field below Fresh celery (position 

3) is Skim milk (position 4), followed by Strawberries (position 9). When 

we click on Strawberries, the number changes to follow our index field. 

Strawberries is now in position 5. The index field displays in a sequential 

order.    
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Tab Order Adjusted Manually – Before and After 

4. Click each successive field tab order box to adjust the flow of numbers. 

Numbers are in sequence. In our example, we clicked on the tab order boxes 

9, 12, 15, and 18 to set the order to be 5 through 8 consecutively.   

 

Additional Tab Order Options 

5. After clicking the tab number at the bottom of the first column, move the 

mouse up to the first field of the second column to continue the sequence. 

Continue clicking each successive tab order number until numbers are in 

sequence. Click anywhere on the canvas to hide the tab order numbers. 
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Additional Tab Order Options 

 

Customize Tab Order using: Continue Tab Order 

The continue tab order feature sets the tab order numbers in sequence, for a 

selected set of fields based on the current index value. As an example, the figure 

below shows the original tab order in the food history form of the E.coli project in 

the projects folder. 

 

Customize Tab Order 
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Here is how you can arrange the order to run down the first column, from Fresh 

celery to Bean sprouts. Then start with Grapes in the second column using 

continue tab order. Follow these steps: 

1. Click and drag a rectangle around the first column of fields. This will select 

just those fields. 

 

Click and Drag Column of Fields  

1. Right-click the canvas and select Tabs > Start New Tab Order. This will 

reorder only the selected fields, beginning with the first tab order number. 

 

Start new tab order 
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2. Click and drag a rectangle around the second column of fields to select 

them. 

 

Grouping tab order 

3. Right-click on the canvas and select Tabs > Continue Tab Order. This will 

reorder the second column of fields continuing from the last tab order number 

used in the previous action. 

  

Continue Tab Order 

Repeat steps 2 and 3 until the fields display in the proper sequence. 
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Disable Tab 

The disable tab feature makes the field essentially a read-only field. You cannot 

place the cursor in a read-only field. In the following examples, Check Code 

calculates the Age field by birth date. Therefore, you can design this form so that 

the cursor skips the Age field by disabling its tab. 

1. Right-click the canvas and select Tabs > Show Tab Order from the context 

menu. 

2. Right-click on the Field Tab order box and select Disable Tab. 

  

Disable Tab 

After disabling the tab for a field, the tab order box becomes red to show that it is no 

longer an adjustable field, and you cannot set the cursor there. Pressing the tab key 

will bypass any disabled tabs.  

 

Bypassing disabled tabs 
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Note: Check Code only runs when the cursor enters a field. If the tab order is 

disabled, Check Code will not run for that field. 
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Templates 

 

Templates are a timesaving feature that allows you to save all or part of your 

project for reuse in other projects. You can share templates with other Epi Info™ 7 

users without sharing project data. For example, you can save and use certain fields 

in a later form you want to build, so you don’t need to re-build the same fields again 

such as if you are working with case demographic information. You can build a 

library of fields that are ready to go in case of a public health emergency. You can 

find saved templates in the Epi Info™ Templates folder using the Extensible 

Markup Language (XML) format. There are four types of templates: field, page, 

form, and project.   

Epi Info™ 7 comes with project and field level templates, showing many of the 

various field types and features of Epi Info™ 7, including Check Code examples. 

You can find a list of templates in the Project Explorer under the templates 

category. 

You can view some of the best methods and practices for Epi Info™ by building 

projects using project and field templates. Try out a new project from one of the 

sample Project Templates in Form Designer and take note of how they work.  
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Project Explorer template 

 

Project Templates 

Since Epi Info™ 7 projects contain one or more forms, and each form has one or 

more pages with fields, project templates contain an example of all the above, 

including saved Check Code already included with the template. Project templates 

are an effective and convenient way to share projects between colleagues without 

including collected data.  

Create a New Project from Template 

You can find template samples in the Project Explorer under Templates > 

Projects. Use one of them to create a new project. 
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1. Double-click the template of choice or select File > New Project from 

Template. The New Project from Template dialog box opens.  

 

 

Project from Template 

2. Select a template from the list. The current name and database type show in 

the fields under New Project and Data. 

3. Edit the Project Name if necessary (optional). The default location for the 

project is the Projects folder within the Epi Info™ folder. Specify another 

location if necessary (optional). 

4. Select the database format from the Data Repository drop-down list. The 

default option is Microsoft Access 2000-2003. SQL Server is also available. To 

use the SQL Server option, you need to have access to a SQL Server 

database. 
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5. Click the browse button (…) to the right of the Data Repository field to enter 

the connection information if you selected SQL Server database. Contact 

your SQL Server database administrator for the required information 

requested in this dialog. 

 

 

SQL Server Database Dialog Box 

 

1. Click OK. Form Designer creates the project and after a few seconds. The 

new project (with form page) displays on the canvas. 

For additional information on creating new projects, refer to the topic Create a 

New Blank Project and Form. 
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Create a Project Template 

There are two options for you when you want to build a project template that 

includes all the forms, pages, fields, and Check Code. Save Project as Template 

allows you to specify a template name and description, and Quick Save Project as 

Template which names the template based on the project name and the current 

date and time. Both options save the template in the same way, but Quick Save 

Project as Template does not allow for custom names and descriptions. 

1. In the Project Explorer, right-click on the project name. The project name is 

the topmost item in the Project Explorer.   

2. From the drop-down list, select Save Project as Template or Quick Save 

Project as Template. If you select Quick Save Project as Template the 

template is immediately saved to the Templates > Projects folder with the 

name of the project and a timestamp. 

 

Save Project as Template 

 

1. If you select Save Project as Template, a pop-up box allows you to add a 

template name and an optional description. 
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 Pop-up box for template description 

1. Click OK. The template saves to the Templates > Projects folder. 

2. To retrieve and send the template to someone, locate the project template in 

the Project Explorer under the Projects folder. 

3. Right-click the template name and select Open Containing Folder. This 

opens the folder in Windows Explorer. Share the XML template file with 

others. Copy and paste the XML template file into an email or save it to a 

shared network location. 
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Open Containing Folder 

Get Template 

If you receive a template from someone else, an easy way to copy the template to the 

correct location within Epi Info™ 7 is to use the Get Template feature.   

1. From the Form Designer menu, select File > Get Template. The Open 

dialog displays. 

2. Locate the template file. 

3. Click Open. The template saves to the corresponding Epi Info 7 > 

Templates folder according to the type of template. If the template is a 

project template, then the New Project from Template dialog box opens. 
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  Get Templates Option in Project Explorer 
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Form and Page Templates 

You can build and use form and page templates in similar ways. Key differences are 

the context menu item selection (right-click to get there). Also, you can use form 

templates and create a single form project. You can only add a page template to a 

form from an existing project.  

Create a Form Template 

If you want the template to include all pages and associated Check Code for a form, 

then right-click the form name in the Project Explorer and select Save Form as 

Template. In the example shown below, the form Surveillance along with its 

three pages, Person, Hospital Info, and Case Report, are included in the 

template along with all associated Check Code. 

 

Save Form as Template 

 

Create a Page Template 

If you want the template to include the contents of a specific page and the Check 

Code for the page fields, then right-click the page name in Project Explorer.  
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1. Select Save Page as Template. In this example, only the selected page 

Hospital Info and its Check Code are in the template. 

 

Save Page as Template 

2. Enter a Template Name. 

 

 

Add Template dialog box 

3. Click OK. The page template saves to the respective folder under Templates 

in the Project Explorer. 
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How to Use Form and Page Templates 

You can use form and page templates in very similar ways. In order to use either 

template, there must be an existing project already open in the Form Designer. The 

difference is that a form template contains instructions to create a set of pages, each 

with one or more fields and Check Code. A page template has only the page layout 

information and instructions to create fields on a single page along with Check 

Code. 

Since all field names and page names must be unique, a new form created from a 

template requires very little additional work. The form is usable after creation from 

the template. 

On the other hand, you can use a page template repeatedly on a form. Because of 

this, during the process of creating the new page from a Page Template, if any field 

names already exist for the form, Epi Info™ 7 automatically appends a number to 

new field name from the template. Epi Info™ 7 does this to avoid having any 

duplicate field names. Unfortunately, this has the side effect of potentially breaking 

the Check Code that may exist for that page template. There is no synchronization 

for field names within the Check Code. Therefore, you must manually update the 

Check Code with new field names. 

To use a Form or Page Template, follow these steps: 

1. With a project open in Form Designer, locate the template in the Project 

Explorer >Templates > Forms for form templates, or Templates > Pages 

for a page template. 

2. If you cannot find the template you need, use the File > Get Template 

feature and browse for the template. 
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3. Click and drag the template to the canvas. Epi Info™ 7 creates the new form 

or page and place it in the Project Explorer. 

4. Click and drag the page to the appropriate position, if you want to change the 

page order for a previously used page template. 

Field Templates  

Field templates allow for easy and concise duplication and sharing of fields and 

enable consistent collection of routine information. When a survey needs to have 

several questions asked in the same way, as in a Likert scale, it is easiest to set up 

one or two or a few of these questions, save them as a field template, then add 

additional sets of questions to the form from the template. This method only 

requires updating the prompt and field name properties of the new fields. 

Each field template includes the field definition and attributes for one or more 

fields, along with any Check Code written for the selected fields. A list of 

demonstration field templates is available in the Project Explorer under Templates 

> Fields. 

How to Create a Field Template 

A convenient way to reuse a field or set of fields along with their Check Code or to 

share fields with a colleague is to create a Field Template.  To do this, follow these 

steps: 

1. Select the fields to add to the template by drawing a rectangle around them. 

To do that, click and drag the mouse from the top left of the desired fields 

diagonally down to the lower right until all required fields are in the blue 

box. 
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Drag a rectangle to Select Fields 

2. Release the mouse button and the selected fields remain highlighted. 

 

Selected Fields appear with blue border 

3. Right click on a blank area of the canvas. Select Save Selection as 

Template from the context menu. 



Epi Info™ 7 User Guide – Form Designer 

124 

 

 

Create New Field Template 

Note: Right clicking on a field or field group will not display the proper menu 

options to create a field template. Right click on a blank portion of the canvas only. 
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4. Enter a Template Name in the Add Template dialog box. 

 

Field Template Name 

5. Click OK. The field template displays under Templates > Fields in the 

Project Explorer.  

Using Field Templates 

To use a Field Template to create a new set of fields, follow these steps: 

1. Locate the Field Template in the Templates>Fields folder in the Project 

Explorer. 
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Field Template drop-down list 

1. If you cannot find the template you need, use the File > Get Template 

feature and browse for the template. 

2. Click and drag the desired template from the Project Explorer onto the 

page location you desire. As you drag the template over the canvas, you will 

see a blue rectangle showing the approximate footprint that the fields will 

occupy when created.  

3. Drop the template where you want to place new fields. Epi Info™ 7 creates 

new fields and copies the associated Check Code into the Check Code Editor. 
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Drag Field Template to Canvas 

Epi Info™ 7 creates fields from Field Templates using the field name specified in 

the template, unless a field by that name already exists anywhere on form. Epi 

Info™ avoids duplicate field names within a form by automatically adding a 

number to current field names. Unfortunately, this has the side effect of potentially 

breaking the Check Code that may exist for new fields. The field names within the 

Check Code are not synchronized.  Therefore, you must manually update the Check 

Code with added field names. 
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4. For each new field created from the template, right click the field, and select 

Properties. The Field Property dialog box for the selected field opens. 

Notice the Field name.   

 

Open the Properties for new fields. 

5. If a form doesn’t have a data table, edit the Field Name and other properties 

as needed. 
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Customize the new fields’ names, question, and properties. 

Sample Field Templates for Demonstration 

There are several demo field templates with the Check Code that are packaged with 

Epi Info™ 7. You can use for data collection, but they’re primarily for feature 

illustrations of Epi Info™ 7.   

Demographics 

The Demographics template has common fields used to for patient information.  

Some of the fields originate from the Public Health Information Network (PHIN) 

vocabulary set such as Sex and Ethnicity Group.  

 

Field Types Illustrated: 

• Text 

• Comment Legal 

Drop Down 

• Phone Number 

• Checkbox 

• Group 

• Number 

• Multiline 

• Command 

Button 
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Demographics Field Template 

Diagnosis 

The diagnosis template contains multiple Yes\No fields related to common patient 

diagnoses. The template also includes text fields for collecting additional 

information. 
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Diagnosis Field Template 

Geo-location 

The geo-location field template contains fields for Address, Latitude, and Longitude. 

It also has a command button, Get Coordinates. We used the GEOCODE 

command to write the Check Code for Get Coordinates. This command uses a 

geolocation service to populate the Latitude and Longitude fields with 

coordinates based on entered locations in the Address field. These coordinates help 

to map functions in the Epi Info™ Maps. 

 

Geo_Location Field Template 
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Medical Facility 

The Medical Facility template contains fields commonly used to collect medical 

facility information. 

 

Medical Facility Field Template 

States 

The States field template is an example of a comment legal field. Comment legal 

fields store only the code or abbreviation in the database, but you can see the full 

description in the drop-down list. The data source for this field includes all state 

and territory names and abbreviations for the United States of America in sorted 

order (alphabetical).   

 

States Field Template 



Epi Info™ 7 User Guide – Form Designer 

133 

 

 

Industry and Occupation 

The Industry and Occupation field template contains eight fields: two input 

fields, five output fields, and a command button. The two input fields are multiline 

text fields for entering free-text descriptions of a subject’s industry and occupation 

of employment.  

The output fields include number fields for industry and occupation codes, multiline 

text fields for industry and occupation titles, and a multiline text field for the coding 

scheme in use.  

The command button, Get I/O Codes, invokes check code written with the IOCODE 

command. This command uses a machine-learned, auto-coding program within Epi 

Info™ to assign both standard industry and occupation codes, based on provided, 

free-text descriptions. The resulting codes and their corresponding titles populate 

the industry and occupation code and title output fields.  

The coding scheme output field is automatically populated with the name of the 

coding scheme used by the auto-coding program. No internet connection is required 

to run the program. No data is transferred outside of Epi Info™ during the coding 

process.      
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Get I/O Codes button  

 

 

Additional Functionality in Form Designer 

 

Insert a Line  

It is sometimes helpful to add a horizontal line between groups of fields to give a 

visual separation between sections of the page. You can create a line using the 

Label/Title field.   

 

Figure 0.1: Horizontal Line Functionality. 
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To create a line on your page, follow these steps: 

1. Right click on the canvas where you want to add a line. Select New Field > 

Label/Title. 

2. In the Question or Prompt field, hold the SHIFT key and type and 

underscore to create a line. 

3. Click the Font button. The Font dialog box opens. 

4. Select a font size and bold. 

5. Click OK. 

6. Create a Field Name for the label field. 

7. Click OK. The line displays in the form. 

8. You can resize the line, move, copy and paste as needed. 

Upgrade Project 

To use a project from a previous version of Epi Info™ in Epi Info™ 7, you must 

upgrade the project to the latest version. The upgrade project tool allows users to 

browse and identify previous projects and upgrade the projects for Epi Info™ 7. 

Select Tools > Upgrade Project > Epi Info 3.5x (.MDB). 

 

Upgrade Project 

Browse and select the desired project. Click Open. Epi Info™ 7 upgrades the 

project to its current version. 
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Make a Project File (PRJ) 

Occasionally, you may receive an Epi Info™ 7 database — either the Access MDB 

file or the location of the database on a SQL Server. If this database is by itself, and 

you do not have the corresponding PRJ file (project file), then Epi Info™ 7 won’t 

work until you create a new PRJ File.   

To create a new PRJ file for a given Epi Info™ 7 database, follow these steps: 

1. From the Form Designer Tools menu, select Make PRJ File. 

 

Make PRJ file 

2. If the database you are attempting to use is a Microsoft Access database, 

MDB, then select From Epi Info™ 7 project (MS Access).  

For a SQL Server database, select From Epi Info™ 7 project (SQL 

Server). 

3. For Access files, browse for the desired MDB file and click Open. The source 

MDB file creates a new PRJ file. You can open the original MDB file again in 

older versions after the migration. Any changes, any changes made to the 

original database will remain, and will not add to the new version. 
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4. For SQL Server databases, you’ll need connection information for the SQL 

Server. See your SQL Server Database Administrator for the connection 

information. 

 

Delete an Existing Data Table Without Deleting the Form 

To delete an existing data table without deleting the form, perform the following 

steps: 

1. From the Form Designer toolbar, select Tools > Delete Data Table. The 

Form Designer warning message displays. 

 

Figure 0.2: Delete Data Table. 

2. Click Yes. This deletes the data table associated with your form. The form 

remains intact. If you have created a relational database setup, deleting the 

data table from the parent form will delete the data tables for any of the child 

forms. 

• Deletion of the data table results in the deletion of any entered data 

associated with the form. Be sure you do not need the records. 

Note: Use this function only if your data is expendable. Your data will be 

unrecoverable. 
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View a Data Dictionary 

The Data Dictionary displays form (s) and defined variables for an open project. 

Fields or variables sort and display by page number in the form, with defined 

variables appearing at the end of the listing. Information retrieved from the form 

includes Page Number, Tab Index, Prompt, Field Type, Name, Variable Type, 

Format, and Special Info. 

From the Form Designer toolbar, select Tools > Data Dictionary. The Data 

Dictionary table displays on the canvas.   

 

 

Data Dictionary 
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• Page Number values are generated as pages are added into a form.  The 

Page Number corresponds to the page location in the Project Explorer. 

• Tab Index corresponds to the tab order for each field. 

• Prompt, Field Type, Name and Variable Type correspond to the 

specifications in the Field Definition dialog box for each variable. 

• The resulting grid shows the name of the fields in the Name column. These 

names correspond to the column names in the data tables you’ll need when 

performing analyses. 

• Format column values include anything with a pattern. Pattern for number, 

date, date-time, phone number fields and sorted for combo boxes. A Combo 

box is a combination of the list box and a drop-down list. 

• Special Info column values include all properties available from the Field 

Definition dialog box. Properties include read only, repeat last, code table, 

groups, required, range, and image size. The Special Info column also 

holds the values for pre-defined variables like standard, global, or 

permanent. During field creation, the Special Info column includes 

information in related fields showing whether they contain one or unlimited 

records. The default is Unlimited Records. If you check the If the Return 

to the Parent Form after One Record has been Entered box, the format 

shows as one record. 

To view a data dictionary for another form: 

1. Click Selected Form/Code Table. The Selected Form/Code Table drop-

down list opens. 
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2. Select the form or code table to view. The Data Dictionary for the selected 

form opens. Note that only the Data Dictionary for the selected form opens. 

To open the Data Dictionary as an HTML page inside the browser window: 

1. Click View/Print as Web Page.  

Note: From the browser, you can print data by going to File > Print or saved with 

File > Save As. 

2. Right-click on the HTML page to show the context menu. You can export the 

data directly to an Excel spreadsheet or print the document. 

 

Data Dictionary as an HTML Page 

3. Click Close to exit the Data Dictionary. 
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Make Form from Data Table 

The Make Form from Data Table feature allows you to auto-generate an Epi Info™ 

7 form with the corresponding data based on an existing database file. Once 

completed, the initial structure of a form is customizable. You can specify field 

types, code reference tables, and field prompts during the process. Formats 

supported include MS Excel, MS Access, .CSV, SQL Server and MySQL, among 

other types. 

For example, you have an Excel spreadsheet with data that you have historically 

maintained. You would like to create an Epi Info™ project and leverage the benefits 

of entering data in Epi Info™ 7. This feature allows users to do so. 

In order to make a form from a data table, complete these steps:  

1. From the Epi Info™ main menu, select Utilities > Make Form from Data 

Table. The Make Form from Table dialog opens. 

2. Select the database type you want. In this example, we will select Microsoft 

MS Excel 97-2003 Workbook. 

3. Navigate to the location of the file. 

4. Click on the name of the spreadsheet that contains the dataset you want to 

import into Epi Info™ 7.  

5. Specify a form name. Click OK. The Table-to-Form dialog opens. 
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Make Form from Table dialog 
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Table-to-Form dialog 

6. Click Set Prompt Font and Set Field Font to set the fonts for the 

question/prompts and the input fields, respectively. 

7. Use Add List Source Table for any Legal Value field columns in the source 

table. Then click and browse for the table containing the list of valid values. 

The ListSourceTableName column requires these values. 

Here is a description of each column: 

▪ Import – This check box allows you to select the fields you want to import 

into the form. You can turn off the import for other fields. All fields are 

checked by default. 

▪ Column Name – This specifies the column name from the source table. The 

column name cannot be edited. 
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▪ Field Name – The field name is initially the same as the column name, but 

you can change it now. If the field name is an Epi Info™ reserved word, the 

Table-to-Form process will change it automatically by adding a suffix of _RW. 

You can change the suffix if you choose. 

Note: Be sure these field names are adequate before starting the 

conversion. You can’t change field names after the data tables are 

created. 

▪ Prompt – The prompt is initially the same as the field name. You can change 

it now, or later by visiting the properties for the field. 

▪ Column Type – Shows the type of data that Epi Info™ 7 detected.  The 

column type cannot be edited.   

▪ Field Type – Specifies the type of field that probably corresponds to the 

Column Type. For example, if Epi Info™ 7 detects string data for the Column 

Type, then it suggests a field type, like a text field. You can override the 

suggestion if you prefer another field type that works better for your data. 

For example, if the column contains only Yes and No values, Epi Info™ may 

suggest the text field, but you may decide the Yes and No field type is more 

appropriate. You can choose from the following field types: Text, Multiline, 

Number, Yes\No, Checkbox, Date, Date-Time, Time, and Legal Values. 

▪ Page – For tables having many columns, Epi Info™ places the fields on the 

form in the order they appear on the source table. It will stack as many fields 

as will fit on the first page and continue to add pages and fields until all the 

columns are full. You can use the Page column to instruct Epi Info™ to 

keep certain fields together on a specific page.   

Note: There is a limit of 250 fields on a page. 
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▪ Tab –The order of the fields within the page during data entry.  

▪ Tab stop – If data entry will occur for a field, then this should remain 

checked. Some fields are automatically calculated, so these would not need a 

tab stop and therefore the Tab stop checkbox should be unchecked. When 

Tab Stop is unchecked, the cursor will not move into the field during data 

entry. 

▪ Read only – This check box sets the Read Only attribute of the field. If 

checked the field is disabled. By default, it is unchecked. 

▪ Required – Fields where data entry is mandatory should have this required 

attribute checked. By default, it is unchecked.  

▪ Repeat last – When checked, the Repeat Last attribute causes the values in 

the most recently viewed record to pre-populate for a new record. By default, 

it is unchecked. 

▪ Range – Allows for a specified value between a range of values. During data 

entry, if you attempt to enter a value outside the specified range, you’ll get a 

warning message that the value is out of range. Missing values are accepted. 

By default, it is unchecked. If you check the Range check box, then also 

specify the Lower and Upper ranges as described below. 

▪ Lower – Specifies the lowest value that can be entered into the field. 

▪ Upper – Specifies the highest value that can be accepted by the field. 

▪ List Source Table Name – Imported reference tables using the Add List 

Source Table option allow for the linking of fields to imported tables. This 

only applies to Legal Value fields. 
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▪ List Source Text Column Name—If multiple columns are available on the 

imported reference table, specify which column name for mapping to fields 

from within the table. 

▪ List Source Table- Remove Fields from the View Fields list using the 

back single arrow or back double arrows. 

8. Click Convert to start the import process. 

Form creation and with data importing. Once the process completes the Table to 

form import process complete message displays. 

 

In Progress dialog window 

 

Process completed dialog window 
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After the import process has completed, you can make some changes to the form, 

such as alignment, font, and adding labels and titles. However, do not cut-and-paste 

fields from one page to another. If you intend to move fields across pages after the 

import, we strongly recommended that you first make a copy of the imported project 

file, then use the  Delete Data Tables option in Form Designer, move the fields to 

the necessary pages, then Use the MERGE Command in Classic Analysis to 

merge the data into the revised form.  

 

Cutting and Pasting fields 

New Project from Data Dictionary 

 

The New Project from Data Dictionary feature allows you to auto-generate Epi 

Info™ 7 forms with fields based on your MS Excel templates. Once you’ve formatted 

your MS Excel template, you can begin building the kind of form you prefer. You 

can customize the form later if you wish. When using the MS Excel template, you 

can specify field prompts, field types, code reference tables, and implement limited 

skip patterns.  

Download the MS Excel template from the Epi Info™ Form Designer section:   

Click here to view an example  under the File > New Project from Data 

Dictionary menu option. The MS Excel template contains the following columns: 
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• Question – Prompts user to create a field. 

• Title – Creates a header shows for each question. This is optional. 

• Description – Optional content for the data entry field displayed with the 

question. 

• Variable_name – Assignment of a field name to the question. 

• Question_type – Specifies the Epi Info™ field type. Only certain field types 

are supported when using this feature; Text, Numeric, Yes/No, Option, 

Dropdown, Date, Time, GPS, Label 

• Required – Attribute that specifies required fields during data collection.  

Parameters accepted in the column are TRUE or FALSE. 

• List_values – Reference the worksheet name in this column, containing the 

list of values corresponding to a dropdown field.  The actual values must be 

listed on a separate worksheet. For example, if you want a drop-down field to 

include the values, Male, Female, and Other, you will add these three values 

in a different worksheet and make a reference to the worksheet name in the 

List_values column. 

• If_Condition – Implement only an IF/THEN/GOTO conditional statement 

using the MS Excel template. Add more conditional assignments using the 

Check Code editor once the form has been created. Add Check code using the 

next three columns in the MS Excel template. For example, if you want a 

skip pattern for a dropdown field, specify the evaluated value in the 

IF_Condition column.  Specify the destination field if the condition is met in 

the THEN_GOTO column, and then use the ELSE_GOTO column to specify 

the next field to move to if the condition is not met.   

• Then_Goto – Specify a field name destination if the condition is met. 

• Else_Goto – Specify a field name destination if the condition is not met. 
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Excel Template for New Project from Data Dictionary 

After adding all your content (fields, and parameters for each column) to the MS 

Excel template you’re ready to create the form using the New Project from Data 

Dictionary feature. 

Create the form using the New Project from Data Dictionary feature, complete these 

steps:  

1. Select File > New Project from Data Dictionary, from the Epi Info™ 

Form Designer module. This shows the New Project from Data 

Dictionary dialog screen. 
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Create New Project from Data Dictionary Window 

2. Navigate to the location of the MS Excel file. 

3. Specify a name for the project. 

4. Specify a name for the form. 

5. Click the browse button and navigate to the location where you would like to 

save the new Epi Info™ project. 

6. Click OK.  
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Epi Info™ starts building the form based on the parameters in the MS Excel 

template. The completed process builds a form containing the fields specified from 

the template.  This feature currently creates one page for each field, but you could 

move around fields from one page to the other using the Form Designer Cut and 

Paste feature. Future releases of Epi Info™ will have the capability of incorporating 

multiple fields within a page. 
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Appendix A:  Reserved Words 

There are certain words in Epi Info™ 7 that may not be used for variable names, 

field names and form names. When the user attempts to use a reserved word for 

any of these elements, a message will be displayed to the user requiring the name of 

the variable, field, or form name to be changed.  Below is a list of the reserved 

words in Epi Info™ 7. 

RESERVED WORDS 
     1 ABSOLUTE        41 CHARACTER        81 

DATEFORMAT"  
      121 
EXCEPTION   

      161 HELP"  

     2 ACTION        42 
CHARACTER_LENGTH   

     82 datetime         122 EXEC         162 HIDE"  

     3 ADA        43 CHECK        83 DAY         123 
EXECUTE   

      163 HIVALUE"  

     4 ADD        44 CLEAR"       84 
DBVALUES"  

      124 EXISTS         164 HOUR   

     5 ALL        45 CLIPBOARD"       85 
DBVARIABLES"  

      125 EXIT"        165 HYPERLINKS"  

     6 ALLOCATE        46 CLOSE        86 DBVIEWS"        126 
EXTERNAL   

      166 identity   

     7 
ALPHANUMERIC   

     47 CLOSEOUT"       87 
DEALLOCATE   

      127 
EXTRACT   

      167 IEEEDOUBLE   

     8  ALTER        48 CMD"       88 DEC         128 FALSE         168 IEEESINGLE   

     9  ALWAYS"       49 COALESCE        89 decimal         129 FETCH         169 IF"  

     10 and        50 CODE               90 DECLARE         130 
FIELDVAR"  

      170 IGNORE"  

     11 ANY        51 COLLATE        91 
DECOMPRESS"  

      131 
FILESPEC"  

      171 IMMEDIATE   

     12 APPEND"       52 COLLATION        92 DEFAULT         132 FIRST         172 IMP   

     13 ARE        53 COLUMN        93 
DEFERRABLE   

      133 FKEY" 
H"); 

      173 in   

     14 AS        54 COLUMNSIZE"       94 DEFERRED         134 float         174 INCLUDE   

     15 asc        55 COMBINE"       95 DEFINE"        135 
FLOAT4   

      175 INDEX   

     16 ASCENDING"       56 COMMANDLINE"       96 delete         136 
FLOAT8   

      176 INDICATOR   

     17 ASSERTION        57 COMMIT        97 DELETED"        137 FOR         177 INITIALLY   

     18 ASSIGN"       58 COMPRESS"       98 
DENOMINATOR"  

      138 
FOREIGN   

      178 INNER   

     19 AT        59 CONNECT        99 desc         139 
FORTRAN   

      179 INPUT   

     20 
AUTHORIZATION   

     60 CONNECTION        100 
DESCENDING"  

      140 
FOUND   

      180 INSENSITIVE   

     21 
AUTOINCREMENT   

     61 constraint        101 DESCRIBE         141 FREQ"        181 INSERT   

     22 
AUTOSEARCH"  

     62 CONSTRAINTS        102 
DESCRIPTOR   

      142 
FREQGRAPH"  

      182 int   

     23 AVG        63 CONTINUE        103 DIALOG"        143 from         183 integer   

     24 BEEP"       64 CONVERT        104 
DISALLOW   

      144 FULL         184 INTEGER1   

     25 BEGIN        65 
CORRESPONDING   

     105 
DISCONNECT   

      145 
GENERAL   

      185 INTEGER2   

     26 BETWEEN        66 count        106 DISPLAY"        146 GET         186 INTEGER4   

     27 BINARY        67 COUNTER        107 DISTINCT         147 
GLOBAL   

      187 INTERSECT   
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     28 bit        68 COXPH"       108 
DISTINCTROW   

      148 
GLOBALID      

      188 INTERVAL   

     29 BIT_LENGTH        69 CREATE        109 
DLLOBJECT"  

      149 GO         189 INTO   

     30 BITMAP"       70 CROSS        110 DOMAIN         150 GOTO         190 IS   

     31 BOOLEAN        71 CURRENCY        111 double         151 GRANT         191 ISOLATION   

     32 BOTH        72 CURRENT        112 DROP         152 
GRAPH"  

      192 JOIN   

     33 BY        73 CURRENT_DATE        113 ELSE         153 
GRAPHTYPE"  

      193 KEY   

     34 byte        74 CURRENT_TIME        114 ELSEIF"        154 
GRIDLINES"  

      194 KEYVARS"  

     35 CASCADE        75 
CURRENT_TIMESTAMP   

     115 END         155 
GRIDTABLE"  

      195 KMSURVIVAL"  

     36 CASCADED        76 CURRENT_USER        116 
ENDBEFORE"  

      156 
GROUP   

      196 LANGUAGE   

     37 CASE        77 CURSOR        117 END-EXEC         157 
GROUPVAR"  

      197 LAST   

     38 CATALOG        78 DATABASE        118 EQV         158 GUID         198 LEADING   

     39 char        79 DATABASES"       119 ESCAPE         159 
HAVING   

      199 LEFT   

     40 
CHAR_LENGTH   

     80 date        120 EXCEPT         160 
HEADER"  

     200 LET"  
 
 

  



Epi Info™ 7 User Guide – Form Designer 

154 

 

     

RESERVED WORDS (continued) 
      201 LEVEL         245 NULLIF         289 RECDELETED"        333 SQLSTATE         377 UNDEFINE"  
      202 like         246 NUMBER         290 RECODE"        334 SQLSTRING         378 UNDELETE"  
      203 LINENUMBERS"        247 numeric         291 RECORDCOUNT"        335 SQLWARNING         379 UNHIDE"  
      204 LINKNAME"        248 OCTET_LENGTH         292 RECSTATUS" H");       336 STARTFROM"        380 UNION   
      205 LIST"        249 OF         293 references         337 STATISTICS"        381 UNIQUE   
      206 LOCAL         250 OFF"        294 REGRESS"        338 STATUSBAR"        382 UNIQUEKEY" H"); 
      207 LOGICAL         251 OLEOBJECT         295 RELATE"        339 STDEV         383 UNKNOWN   
      208 LOGICAL1         252 on         296 RELATIVE         340 STDEVP         384 update   
      209 LOGISTIC"        253 ONLY         297 REPLACE"        341 STRATAVAR"        385 UPPER   
      210 LONG         254 OPEN         298 REPORT"        342 SUBSTRING         386 USAGE   
      211 LONGBINARY         255 OPTION         299 REPORTDATA"        343 SUM         387 USEBROWSER"  
      212 LONGTEXT         256 or         300 RESPONSEVAR"        344 SUMOF"        388 USER   
      213 LOVALUE"        257 ORDER         301 RESTRICT         345 SYSTEM_USER         389 USING   
      214 LOWER         258 OUTER         302 REVOKE         346 SYSTEMDATE"        390 VALUE   
      215 MAP"        259 OUTPUT         303 RIGHT         347 SYSTEMTIME"        391 values   
      216 MATCH         260 OUTTABLE"        304 ROLLBACK         348 SYSLATITUDE        392 VALUEVAR"  
      217 MATCHING"        261 OVERLAPS         305 ROUTEOUT"        349 SYSLONGITUDE       393 VAR   
      218 MATCHVAR"        262 OVERLAYNEXT"        306 ROWS         350 SYSBARCODE         394 varbinary   
      219 MAX         263 OWNERACCESS         307 RUNPGM"        351 TABLE         397 varchar   
      220 MEANS"        264 PAD         308 RUNSILENT"        352 TABLEID         398 VARP   
      221 MEMO         265 PARAMETERS         309 SCHEMA         353 TABLES"        399 VARYING   
      222 MERGE"        266 PARTIAL         310 SCROLL         354 TEMPLATE"        400 VIEW   
      223 min         267 PASCAL         311 SECOND         355 TEMPORARY         401 VIEWNAME"  
      224 MINUTE         268 PERCENT         312 SECTION         356 text         402 WEIGHTVAR"  
      225 MISSING"        269 PERCENTS"        313 SELECT         357 TEXTFONT"        403 WHEN   
      226 MOD"        270 PERMANENT"        314 SESSION         358 TEXTINPUT"        404 WHENEVER   
      227 MODDATE            271 PGMNAME"        315 SESSION_USER         359 THEN         405 where   
      228 MODULE         272 PIVOT         316 set         360 THREED"        406 WITH   
      229 MODUSER            273 POSITION         317 SHORT         361 TIME         407 WORK   
      230 money         274 PRECISION         318 SHOWOBSERVED"        362 timestamp         408 WRITE   
      231 MONTH         275 PREPARE         319 SHOWPROMPTS"        363 TIMEUNIT"        409 XOR"  
      232 MULTIGRAPH"        276 PRESERVE         320 SHOWSINGLECASES"        364 TIMEVAR"        410 YEAR   
      233 NAMES         277 PRIMARY         321 single        365 TIMEZONE_HOUR         411 YESNO   
      234 NATURAL         278 PRINTOUT"        322 SIZE    366 TIMEZONE_MINUTE         412 YN"  
      235 nchar         279 PRIOR         323 smallint         367 TITLETEXT"        413 ZONE   
      236 NEWPAGE"        280 PRIVILEGES         324 SOME         368 TO         414 CANCEL"  
      237 NEXT         281 PROCEDURE         325 SORT"        369 TOP         415 REPEAT"  
      238 NO         282 PROCESS"        326 SPACE         370 TRAILING    
      239 NOIMAGE"        283 PSUVAR"        327 SQL         371 TRANSACTION    
      240 NOINTERCEPT"        284 PUBLIC         328 SQLCA         372 TRANSFORM    
      241 NONE         285 PVALUE"        329 SQLCODE         373 TRANSLATE    
      242 NOT         286 QUIT"        330 SQLERROR         374 TREE    
      243 NOWRAP"        287 READ         331 SQLNULL         375 TRIM    
      244 null         288 real         332 SQLREAL         376 TYPEOUT"   
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